aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-11 21:59:47 +0800
committertijl <tijl@FreeBSD.org>2014-08-11 21:59:47 +0800
commit14f6eac5328c6e0318432ff56f2ed8c4925d7b3d (patch)
tree2015e43bc8319ab8afc24049da6744399385736d /comms
parent1aae2fcc1314dead2f9fd1d29bd26f1ebce013e4 (diff)
downloadfreebsd-ports-gnome-14f6eac5328c6e0318432ff56f2ed8c4925d7b3d.tar.gz
freebsd-ports-gnome-14f6eac5328c6e0318432ff56f2ed8c4925d7b3d.tar.zst
freebsd-ports-gnome-14f6eac5328c6e0318432ff56f2ed8c4925d7b3d.zip
comms/lirc:
- Fix missing -lusb [1] - Convert to USES=libtool and bump dependent ports - Add INSTALL_TARGET=install-strip - Use @sample Reported by: sbruno [1]
Diffstat (limited to 'comms')
-rw-r--r--comms/lirc/Makefile27
-rw-r--r--comms/lirc/pkg-plist8
-rw-r--r--comms/py-lirc/Makefile2
3 files changed, 18 insertions, 19 deletions
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 7cc6381240d1..6e5d9b4d535c 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lirc
PORTVERSION= 0.9.0
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= SF/${PORTNAME}/LIRC/${PORTVERSION}
@@ -14,19 +14,19 @@ COMMENT= Linux Infrared Remote Control
BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
-USE_AUTOTOOLS= libtool automake autoheader aclocal autoconf
-USES= gmake tar:bzip2
-ACLOCAL_ARGS= -I "${ACLOCAL_DIR}" -I ${LOCALBASE}/share/aclocal
+INSTALL_TARGET= install-strip
+USES= gmake libtool tar:bzip2
+USE_AUTOTOOLS= libtoolize automake autoheader aclocal autoconf
+AUTOMAKE_ARGS= -a -c -f
USE_XORG= sm x11
USE_PYTHON= yes
USE_CSTD= gnu89
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
- --sysconfdir=${PREFIX}/etc
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
+ --sysconfdir=${PREFIX}/etc
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC DOCS EXAMPLES
@@ -63,10 +63,11 @@ CONFIGURE_ARGS+= --enable-debug
RUN_DEPENDS+= uartlirc>=0.3:${PORTSDIR}/comms/uartlirc
.endif
-# XXX: work around an issue with automake-1.13 erroring out on a
-# non-existent m4 directory before libtoolize creates it
-pre-configure::
- @${MKDIR} ${WRKSRC}/m4
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's/`$${LIBUSB_CONFIG} --libs`/-lusb/' \
+ -e 's/`$${LIBUSB_CONFIG} --cflags`//' \
+ ${WRKSRC}/configure.ac
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/comms/lirc/pkg-plist b/comms/lirc/pkg-plist
index ae72a95243b0..ca8293461299 100644
--- a/comms/lirc/pkg-plist
+++ b/comms/lirc/pkg-plist
@@ -12,9 +12,9 @@ bin/pronto2lirc
bin/xmode2
include/lirc/lirc_client.h
lib/liblirc_client.a
-lib/liblirc_client.la
lib/liblirc_client.so
-lib/liblirc_client.so.2
+lib/liblirc_client.so.0
+lib/liblirc_client.so.0.2.1
man/man1/ircat.1.gz
man/man1/irexec.1.gz
man/man1/irpty.1.gz
@@ -31,8 +31,6 @@ man/man8/lircmd.8.gz
sbin/lircd
sbin/lircmd
@dirrm include/lirc
-@unexec if cmp -s %D/etc/lircd.conf.sample %D/etc/lircd.conf; then rm -f %D/etc/lircd.conf; fi
-etc/lircd.conf.sample
-@exec if [ ! -f %D/etc/lircd.conf ] ; then cp -p %D/%F %B/lircd.conf; fi
+@sample etc/lircd.conf.sample
@exec mkdir -p /var/run/lirc
@unexec rmdir /var/run/lirc 2> /dev/null || true
diff --git a/comms/py-lirc/Makefile b/comms/py-lirc/Makefile
index 47cb3a81201f..265942d2985e 100644
--- a/comms/py-lirc/Makefile
+++ b/comms/py-lirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lirc
PORTVERSION= 0.0.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}