aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2000-09-29 00:41:51 +0800
committerobrien <obrien@FreeBSD.org>2000-09-29 00:41:51 +0800
commit932e01c843dd2bf72e18c3af9341cad521db9a2e (patch)
treeec03e3d8f84bceb76646c670cab902c562aec5c4 /comms
parent50aa8f27c95cbf6e9d99344df705e1fac370af8e (diff)
downloadfreebsd-ports-gnome-932e01c843dd2bf72e18c3af9341cad521db9a2e.tar.gz
freebsd-ports-gnome-932e01c843dd2bf72e18c3af9341cad521db9a2e.tar.zst
freebsd-ports-gnome-932e01c843dd2bf72e18c3af9341cad521db9a2e.zip
Use _PATH_UUCPLOCK from path.h rather than /var/spool/uucp.
Requested by: Daniel O'Connor <doconnor@gsoft.com.au>
Diffstat (limited to 'comms')
-rw-r--r--comms/minicom/Makefile1
-rw-r--r--comms/minicom/files/patch-ai23
2 files changed, 21 insertions, 3 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 057a132f2c54..5e2c155d1b12 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -8,6 +8,7 @@
PORTNAME= minicom
PORTVERSION= 1.83.1
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.pp.clinet.fi/~walker/mc-dev/ \
diff --git a/comms/minicom/files/patch-ai b/comms/minicom/files/patch-ai
index 104b21d29a71..a1cefc1255c8 100644
--- a/comms/minicom/files/patch-ai
+++ b/comms/minicom/files/patch-ai
@@ -1,6 +1,23 @@
---- config.h.orig Fri Oct 31 11:48:00 1997
-+++ config.h Thu Jul 22 02:30:39 1999
-@@ -58,7 +58,7 @@
+--- config.h.orig Wed Mar 15 08:25:21 2000
++++ config.h Thu Sep 28 09:38:44 2000
+@@ -18,10 +18,16 @@
+ * and adjust them to your system.
+ */
+
++#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
++#include <paths.h>
++#endif
++
+ /* Operating system INdependant parameters. (Usually the same everywhere) */
+ #define KERMIT "/usr/local/bin/kermit -l %l -b %b" /* How to call kermit */
+ #ifdef SVR4_LOCKS
+ # define UUCPLOCK "/var/spool/locks" /* SVR4 version of Lock file directory */
++#elif defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
++# define UUCPLOCK _PATH_UUCPLOCK /* Lock file directory */
+ #else
+ # define UUCPLOCK "/var/spool/uucp" /* Lock file directory */
+ #endif
+@@ -62,7 +68,7 @@
#ifdef __FreeBSD__
# define DFL_PORT "/dev/modem"