aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
committerrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
commitbc9eaafddac55414d201b6636e63508ce80779b9 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /comms
parent74e9373bcd181bd5e011c695cd6ff38aeea7d44b (diff)
downloadfreebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.gz
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.zst
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Diffstat (limited to 'comms')
-rw-r--r--comms/uhso-kmod/Makefile11
-rw-r--r--comms/uhso-kmod/pkg-plist5
2 files changed, 5 insertions, 11 deletions
diff --git a/comms/uhso-kmod/Makefile b/comms/uhso-kmod/Makefile
index e973caaa2daa..ef5f3e0b7f0b 100644
--- a/comms/uhso-kmod/Makefile
+++ b/comms/uhso-kmod/Makefile
@@ -4,7 +4,7 @@
PORTNAME= uhso
PORTVERSION= 20100416
PORTREVISION= 2
-CATEGORIES= comms kld
+CATEGORIES= comms
MASTER_SITES= http://www.shapeshifter.se/pub/hso/
PKGNAMESUFFIX= -kmod
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
@@ -27,18 +27,15 @@ OPTIONS_DEFAULT= UHSOCTL
UHSOCTL_DESC= Build uhsoctl tool
SUB_FILES= pkg-message
-KMODDIR?= /boot/modules
-PLIST_SUB+= KMODDIR=${KMODDIR}
-MAKE_ENV+= KMODDIR=${KMODDIR}
MAN4= uhso.4
NO_STAGE= yes
+
+USES= kmod
.include <bsd.port.pre.mk>
-.if !exists(${SRC_BASE}/sys/Makefile)
-IGNORE= requires kernel source files
-.elif ${OSVERSION} <= 800063
+.if ${OSVERSION} <= 800063
IGNORE= requires FreeBSD 8.0 or later, please try comms/hso-kmod instead
.elif ${OSVERSION} >= 800501
IGNORE= the uhso driver is already available in the base system
diff --git a/comms/uhso-kmod/pkg-plist b/comms/uhso-kmod/pkg-plist
index bbd6078ac0f0..571e74fa8118 100644
--- a/comms/uhso-kmod/pkg-plist
+++ b/comms/uhso-kmod/pkg-plist
@@ -1,5 +1,2 @@
%%PL_UHSOCTL%%bin/uhsoctl
-@cwd /boot/modules
-uhso.ko
-@exec kldxref %D
-@unexec kldxref %D
+/%%KMODDIR%%/uhso.ko