aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-29 07:04:48 +0800
committeredwin <edwin@FreeBSD.org>2003-09-29 07:04:48 +0800
commitc2e825261a8114c859ff0ed1d876e1484dd12acf (patch)
treee1a270e003b85f317ee9374265005ebc3da4fab1 /comms
parent1cd93fb3e588eecd5a885d96515a573c0e783007 (diff)
downloadfreebsd-ports-gnome-c2e825261a8114c859ff0ed1d876e1484dd12acf.tar.gz
freebsd-ports-gnome-c2e825261a8114c859ff0ed1d876e1484dd12acf.tar.zst
freebsd-ports-gnome-c2e825261a8114c859ff0ed1d876e1484dd12acf.zip
lrz in lrzsz-0.12.20(comms/lrzsz) sets invalid timestamp
When I send a file from Windows with Tera Term Pro and receive it by lrz on FreeBSD, the timestamp (modification time) of the received file is always set to 1991-Apr-20 03:36:12 GMT (which may change according to compiler's optimization), neither the original file's timestamp nor the time that the file was transferred. PR: ports/49999 Submitted by: IIJIMA Hiromitsu <delmonta@ht.sakura.ne.jp>
Diffstat (limited to 'comms')
-rw-r--r--comms/lrzsz/Makefile1
-rw-r--r--comms/lrzsz/files/patch-src::lrz.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/comms/lrzsz/Makefile b/comms/lrzsz/Makefile
index b518d5fbcbf9..8ddcf1843c81 100644
--- a/comms/lrzsz/Makefile
+++ b/comms/lrzsz/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lrzsz
PORTVERSION= 0.12.20
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.ohse.de/uwe/releases/ \
http://www.netsw.org/net/modem/protocols/zmodem/lrzsz/
diff --git a/comms/lrzsz/files/patch-src::lrz.c b/comms/lrzsz/files/patch-src::lrz.c
new file mode 100644
index 000000000000..9a1af487d185
--- /dev/null
+++ b/comms/lrzsz/files/patch-src::lrz.c
@@ -0,0 +1,15 @@
+--- src/lrz.c.orig Sun Sep 28 16:02:13 2003
++++ src/lrz.c Sun Sep 28 16:02:34 2003
+@@ -1159,9 +1159,9 @@
+
+ nameend = name + 1 + strlen(name);
+ if (*nameend) { /* file coming from Unix or DOS system */
+- long modtime;
+- long bytes_total;
+- int mode;
++ long modtime=0;
++ long bytes_total=DEFBYTL;
++ int mode=0;
+ sscanf(nameend, "%ld%lo%o", &bytes_total, &modtime, &mode);
+ zi->modtime=modtime;
+ zi->bytes_total=bytes_total;