aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-08-14 21:00:15 +0800
committermadpilot <madpilot@FreeBSD.org>2013-08-14 21:00:15 +0800
commitfcf23c4db739afd410aa62dbf6fe11dc0cc74d94 (patch)
tree3836608a3e5cc2693fb9db3059c917ff9dda1099 /comms
parentd5f8f641238609f085772e4a86f6c39134a1d083 (diff)
downloadfreebsd-ports-gnome-fcf23c4db739afd410aa62dbf6fe11dc0cc74d94.tar.gz
freebsd-ports-gnome-fcf23c4db739afd410aa62dbf6fe11dc0cc74d94.tar.zst
freebsd-ports-gnome-fcf23c4db739afd410aa62dbf6fe11dc0cc74d94.zip
- Add patch to avoid a bus error while starting the software.
Many thanks to the Mike Bernard for reporting and helping me debug this problem. While here remove obsolete MAKE_JOBS_SFE flag Reported by: Mike Barnard Kwatampora <mike.barnardq@gmail.com>
Diffstat (limited to 'comms')
-rw-r--r--comms/gnokii/Makefile3
-rw-r--r--comms/gnokii/files/patch-common-cfgreader.c20
2 files changed, 21 insertions, 2 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index ea4a56fd911d..cbbe92c96686 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnokii
PORTVERSION= 0.6.31
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -23,7 +23,6 @@ USE_BZIP2= yes
USES= gettext gmake
USE_LDCONFIG= yes
USE_CSTD= gnu89
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
USE_GNOME= intltool
GNU_CONFIGURE= yes
diff --git a/comms/gnokii/files/patch-common-cfgreader.c b/comms/gnokii/files/patch-common-cfgreader.c
new file mode 100644
index 000000000000..592353029aff
--- /dev/null
+++ b/comms/gnokii/files/patch-common-cfgreader.c
@@ -0,0 +1,20 @@
+--- common/cfgreader.c.orig 2011-12-02 15:53:04.000000000 +0100
++++ common/cfgreader.c 2013-08-13 13:25:46.836652059 +0200
+@@ -991,7 +991,7 @@
+ #define CHECK_SIZE() if (*retval >= size) { \
+ void *aux; \
+ size *= 2; \
+- aux = realloc(config_file_locations, size); \
++ aux = realloc(config_file_locations, size * sizeof(char *)); \
+ if (aux) \
+ config_file_locations = aux; \
+ else {\
+@@ -1107,7 +1107,7 @@
+ if (i >= xcd_size) {
+ void *aux;
+ xcd_size *= 2;
+- aux = realloc(xdg_config_dir, xcd_size);
++ aux = realloc(xdg_config_dir, xcd_size * sizeof(char *));
+ if (aux)
+ xdg_config_dir = aux;
+ else {