aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorshurd <shurd@FreeBSD.org>2015-11-28 04:57:14 +0800
committershurd <shurd@FreeBSD.org>2015-11-28 04:57:14 +0800
commit194f84ec83bd08974438984217fb654adc6f2a61 (patch)
tree887d38769b81a35be22d756b3e91168c60fd5bfc /comms
parent85e255da6baf01cd68ada062103ec699183bb540 (diff)
downloadfreebsd-ports-gnome-194f84ec83bd08974438984217fb654adc6f2a61.tar.gz
freebsd-ports-gnome-194f84ec83bd08974438984217fb654adc6f2a61.tar.zst
freebsd-ports-gnome-194f84ec83bd08974438984217fb654adc6f2a61.zip
Update to latest release.
Diffstat (limited to 'comms')
-rw-r--r--comms/quisk/Makefile2
-rw-r--r--comms/quisk/distinfo4
-rw-r--r--comms/quisk/files/patch-microphone.c11
-rw-r--r--comms/quisk/files/patch-setup.py8
4 files changed, 18 insertions, 7 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index bf53c3bdd456..3e440273372a 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= quisk
-PORTVERSION= 3.7.4
+PORTVERSION= 4.0.1
CATEGORIES= comms hamradio
MASTER_SITES= http://james.ahlstrom.name/quisk/ \
LOCAL/shurd
diff --git a/comms/quisk/distinfo b/comms/quisk/distinfo
index 2cd1495e2bdc..ff978336f1aa 100644
--- a/comms/quisk/distinfo
+++ b/comms/quisk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (quisk-3.7.4.tar.gz) = 18b1895d098b0e087d6ae9fa38859fc46e6f5d3c92b2efbe40d1d79719ad4c59
-SIZE (quisk-3.7.4.tar.gz) = 2207348
+SHA256 (quisk-4.0.1.tar.gz) = 3e2b7b2509087521123c68f3f435d0b5958295dbcec8047d44360a2717c979ca
+SIZE (quisk-4.0.1.tar.gz) = 1994100
diff --git a/comms/quisk/files/patch-microphone.c b/comms/quisk/files/patch-microphone.c
new file mode 100644
index 000000000000..a08ad2fafb31
--- /dev/null
+++ b/comms/quisk/files/patch-microphone.c
@@ -0,0 +1,11 @@
+--- microphone.c.orig 2015-11-27 20:43:24 UTC
++++ microphone.c
+@@ -56,7 +56,7 @@ static int timeVOX = 2000; // VOX han
+
+ static int doTxCorrect = 0; // Corrections for UDP sample transmit
+ static double TxCorrectLevel;
+-static complex TxCorrectDc;
++static complex double TxCorrectDc;
+
+ // Used for the Hermes protocol
+ #define HERMES_TX_BUF_SAMPLES 4800
diff --git a/comms/quisk/files/patch-setup.py b/comms/quisk/files/patch-setup.py
index 28fda8441342..69b0eaa4527f 100644
--- a/comms/quisk/files/patch-setup.py
+++ b/comms/quisk/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2014-06-01 15:30:01.000000000 -0700
-+++ setup.py 2014-06-01 15:31:15.000000000 -0700
-@@ -11,8 +11,8 @@
+--- setup.py.orig 2015-11-27 20:41:34 UTC
++++ setup.py
+@@ -12,8 +12,8 @@ fp.write("#QUISK version %s\n" % Version
fp.close()
module1 = Extension ('quisk._quisk',
@@ -8,6 +8,6 @@
- #library_dirs = ['.'],
+ include_dirs = ['%%LOCALBASE%%/include/portaudio2', '%%LOCALBASE%%/include'],
+ library_dirs = ['%%LOCALBASE%%/lib/portaudio2', '%%LOCALBASE%%/lib'],
- libraries = ['asound', 'portaudio', 'pulse-simple', 'fftw3', 'm'],
+ libraries = ['asound', 'portaudio', 'pulse', 'fftw3', 'm'],
sources = ['quisk.c', 'sound.c', 'sound_alsa.c', 'sound_portaudio.c', 'sound_pulseaudio.c',
'is_key_down.c', 'microphone.c', 'utility.c',