aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /comms
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'comms')
-rw-r--r--comms/hamlib/Makefile2
-rw-r--r--comms/hamlib/files/patch-Makefile.am11
-rw-r--r--comms/libirman/Makefile2
-rw-r--r--comms/libirman/files/patch-Makefile.in9
-rw-r--r--comms/rtl-sdr/Makefile4
-rw-r--r--comms/unixcw/Makefile2
-rw-r--r--comms/unixcw/files/patch-src_libcw_Makefile.in11
7 files changed, 4 insertions, 37 deletions
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 950190489481..bbd8df22a70a 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= swig:devel/swig13
LIB_DEPENDS= libltdl.so:devel/libltdl
INFO= hamlib
-USES= autoreconf libtool:keepla pathfix perl5 pkgconfig python shebangfix tcl
+USES= autoreconf libtool:keepla pathfix perl5 pathfix pkgconfig python shebangfix tcl
USE_PYTHON= py3kplist
SHEBANG_FILES= bindings/perltest.pl
USE_PERL5= build run
diff --git a/comms/hamlib/files/patch-Makefile.am b/comms/hamlib/files/patch-Makefile.am
deleted file mode 100644
index 85ed5161ec6b..000000000000
--- a/comms/hamlib/files/patch-Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.am.orig 2015-09-19 12:08:54 UTC
-+++ Makefile.am
-@@ -3,7 +3,7 @@
- aclocaldir = $(datadir)/aclocal
- aclocal_DATA = hamlib.m4
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = hamlib.pc
-
- EXTRA_DIST = PLAN TODO LICENSE hamlib.m4 hamlib.pc.in README.developer \
diff --git a/comms/libirman/Makefile b/comms/libirman/Makefile
index 8304dc78a337..08562e30f111 100644
--- a/comms/libirman/Makefile
+++ b/comms/libirman/Makefile
@@ -11,7 +11,7 @@ COMMENT= Library for Evation's Irman infrared receiver
LICENSE= LGPL20
-USES= gmake libtool tar:bzip2
+USES= gmake libtool pathfix tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/comms/libirman/files/patch-Makefile.in b/comms/libirman/files/patch-Makefile.in
index 5e57722e0f4a..5a9d3920751c 100644
--- a/comms/libirman/files/patch-Makefile.in
+++ b/comms/libirman/files/patch-Makefile.in
@@ -1,14 +1,5 @@
--- Makefile.in.orig 2015-08-18 19:51:04 UTC
+++ Makefile.in
-@@ -399,7 +399,7 @@ top_srcdir = @top_srcdir@
- AUTOMAKE_OPTIONS = foreign dist-bzip2
- ACLOCAL_AMFLAGS = -I m4
- dist_doc_DATA = README TECHNICAL
--pkgconfigdir = @libdir@/pkgconfig
-+pkgconfigdir = @prefix@/libdata/pkgconfig
- dist_pkgconfig_DATA = libirman.pc
- EXTRA_DIST = COPYING.lib TECHNICAL libirman.pc.in
- EXTRA_LTLIBRARIES = libirman_sw.la
@@ -778,7 +778,7 @@ install-dist_sysconfDATA: $(dist_sysconf
done | $(am__base_list) | \
while read files; do \
diff --git a/comms/rtl-sdr/Makefile b/comms/rtl-sdr/Makefile
index eabb26d9621d..741c227324c4 100644
--- a/comms/rtl-sdr/Makefile
+++ b/comms/rtl-sdr/Makefile
@@ -13,7 +13,7 @@ COMMENT= Commandline tool that performs SDR with RTL2832-based USB sticks
LICENSE= GPLv2
-USES= autoreconf gmake pkgconfig libtool tar:tgz
+USES= autoreconf gmake pkgconfig libtool pathfix tar:tgz
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
@@ -31,7 +31,5 @@ DOXYGEN_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Makefile.am
post-patch:
@${REINPLACE_CMD} 's|^pkgdocdir=.*|pkgdocdir=${DOCSDIR}|' \
${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} 's|^pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.am
.include <bsd.port.mk>
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
index 00fb3b223051..1866fc610e26 100644
--- a/comms/unixcw/Makefile
+++ b/comms/unixcw/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+= --includedir="${LOCALBASE}/include" \
--disable-alsa --disable-pulseaudio
USE_LDCONFIG= yes
-USES+= gmake libtool ncurses pkgconfig
+USES+= gmake libtool ncurses pathfix pkgconfig
USE_CSTD= gnu99
WRKSRC= ${WRKDIR}/unixcw-${PORTVERSION}
MAJOR_LIB_VER= 6
diff --git a/comms/unixcw/files/patch-src_libcw_Makefile.in b/comms/unixcw/files/patch-src_libcw_Makefile.in
deleted file mode 100644
index 62f8fe48b9d7..000000000000
--- a/comms/unixcw/files/patch-src_libcw_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/libcw/Makefile.in.orig 2015-10-06 17:17:18 UTC
-+++ src/libcw/Makefile.in
-@@ -676,7 +676,7 @@ libcw_test_internal_LDADD = -lm -lpthrea
- libcw_test_internal_CFLAGS = -rdynamic
-
- # target: libcw.pc
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = ${prefix}/libdata/pkgconfig
-
- # CLEANFILES extends list of files that need to be removed when
- # calling "make clean"