aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2016-03-01 11:41:14 +0800
committerdb <db@FreeBSD.org>2016-03-01 11:41:14 +0800
commit625bc31a67d5466fa20a68506918b33ebe0f33c8 (patch)
treeb9092704a7b078cee5078728f00fe7a848b23a14 /comms
parent4d8dfc4d5397ef47ba948db4a83e1c7fe88c8cdd (diff)
downloadfreebsd-ports-gnome-625bc31a67d5466fa20a68506918b33ebe0f33c8.tar.gz
freebsd-ports-gnome-625bc31a67d5466fa20a68506918b33ebe0f33c8.tar.zst
freebsd-ports-gnome-625bc31a67d5466fa20a68506918b33ebe0f33c8.zip
A simple software defined radio (SDR) library.
Although being simple, libsdr is sufficient to write a simple SDR receiver application (github.com/hmatuschek/sdr-rx, above). This RX application supports several input sources (i.e. sound card, files, RTL2382 dongles etc.) and modes (i.e. AM, FM, SSB, CW, etc.). WWW: https://github.com/hmatuschek/libsdr PR: 207379 Submitted by: Jeffrey Baitis <baitisj@pcbsd.org>
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/libsdr/Makefile29
-rw-r--r--comms/libsdr/distinfo2
-rw-r--r--comms/libsdr/files/patch-CMakeLists.txt10
-rw-r--r--comms/libsdr/pkg-descr7
-rw-r--r--comms/libsdr/pkg-plist32
6 files changed, 81 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 9cdbfd3fd75e..9c3ca1992d23 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -87,6 +87,7 @@
SUBDIR += libirman
SUBDIR += libmodbus
SUBDIR += librs232
+ SUBDIR += libsdr
SUBDIR += libticables2
SUBDIR += libticalcs2
SUBDIR += libusbmuxd
diff --git a/comms/libsdr/Makefile b/comms/libsdr/Makefile
new file mode 100644
index 000000000000..4f8a6b031880
--- /dev/null
+++ b/comms/libsdr/Makefile
@@ -0,0 +1,29 @@
+# Created by: Jeffrey Baitis <baitisj@pcbsd.org>
+# $FreeBSD$
+
+PORTNAME= libsdr
+PORTVERSION= 0.1.0
+CATEGORIES= comms hamradio
+
+MAINTAINER= baitisj@pcbsd.org
+COMMENT= Simple software defined radio (SDR) library
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libportaudio.so:${PORTSDIR}/audio/portaudio \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libfftw3f.so:${PORTSDIR}/math/fftw3-float \
+ librtlsdr.so:${PORTSDIR}/comms/rtl-sdr
+
+USE_GITHUB= yes
+GH_ACCOUNT= hmatuschek
+GH_PROJECT= libsdr
+GH_TAGNAME= 0982a68
+
+MAKE_JOBS_UNSAFE= yes
+USES= cmake pkgconfig
+CMAKE_ARGS+=-DCMAKE_BUILD_TYPE=RELEASE
+CMAKE_VERBOSE= 1
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/comms/libsdr/distinfo b/comms/libsdr/distinfo
new file mode 100644
index 000000000000..8940ee5b2cc1
--- /dev/null
+++ b/comms/libsdr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hmatuschek-libsdr-0.1.0-0982a68_GH0.tar.gz) = 2ee8fd0e7f9d495d8335cc054aa51913bda068fc47395a37873dc16ac250bccb
+SIZE (hmatuschek-libsdr-0.1.0-0982a68_GH0.tar.gz) = 108345
diff --git a/comms/libsdr/files/patch-CMakeLists.txt b/comms/libsdr/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..52780aed75ff
--- /dev/null
+++ b/comms/libsdr/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2015-01-12 13:06:37 UTC
++++ CMakeLists.txt
+@@ -30,6 +30,7 @@ ENDIF(FFTW_FOUND)
+
+ IF(PORTAUDIO_FOUND)
+ set(SDR_WITH_PORTAUDIO ON)
++ set(PORTAUDIO_LIBRARIES)
+ ELSE(PORTAUDIO_FOUND)
+ set(PORTAUDIO_LIBRARIES)
+ ENDIF(PORTAUDIO_FOUND)
diff --git a/comms/libsdr/pkg-descr b/comms/libsdr/pkg-descr
new file mode 100644
index 000000000000..1fd7445dec98
--- /dev/null
+++ b/comms/libsdr/pkg-descr
@@ -0,0 +1,7 @@
+A simple software defined radio (SDR) library.
+Although being simple, libsdr is sufficient to write a simple SDR receiver
+application (github.com/hmatuschek/sdr-rx, above). This RX application
+supports several input sources (i.e. sound card, files, RTL2382 dongles etc.)
+and modes (i.e. AM, FM, SSB, CW, etc.).
+
+WWW: https://github.com/hmatuschek/libsdr
diff --git a/comms/libsdr/pkg-plist b/comms/libsdr/pkg-plist
new file mode 100644
index 000000000000..d111f4a0d940
--- /dev/null
+++ b/comms/libsdr/pkg-plist
@@ -0,0 +1,32 @@
+include/libsdr/autocast.hh
+include/libsdr/baseband.hh
+include/libsdr/buffer.hh
+include/libsdr/buffernode.hh
+include/libsdr/combine.hh
+include/libsdr/config.hh
+include/libsdr/demod.hh
+include/libsdr/exception.hh
+include/libsdr/fftplan.hh
+include/libsdr/fftplan_fftw3.hh
+include/libsdr/fftplan_native.hh
+include/libsdr/filternode.hh
+include/libsdr/firfilter.hh
+include/libsdr/freqshift.hh
+include/libsdr/interpolate.hh
+include/libsdr/logger.hh
+include/libsdr/math.hh
+include/libsdr/node.hh
+include/libsdr/operators.hh
+include/libsdr/options.hh
+include/libsdr/portaudio.hh
+include/libsdr/psk31.hh
+include/libsdr/queue.hh
+include/libsdr/rtlsource.hh
+include/libsdr/sdr.hh
+include/libsdr/siggen.hh
+include/libsdr/subsample.hh
+include/libsdr/traits.hh
+include/libsdr/utils.hh
+include/libsdr/wavfile.hh
+lib/libsdr.so
+lib/libsdr.so.0.1.0