aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-16 00:46:55 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-16 00:46:55 +0800
commit6414130614e60c5b97ef32058ae07377d94f7074 (patch)
treeeb1391835f44f6f5c9414fa141f11fd8ba7ed117 /comms
parent2aa400d97e5806df3b3f289f79875ca4fbc32acb (diff)
downloadfreebsd-ports-gnome-6414130614e60c5b97ef32058ae07377d94f7074.tar.gz
freebsd-ports-gnome-6414130614e60c5b97ef32058ae07377d94f7074.tar.zst
freebsd-ports-gnome-6414130614e60c5b97ef32058ae07377d94f7074.zip
- use OPTIONS_DEFINE
Diffstat (limited to 'comms')
-rw-r--r--comms/hylafax/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index fb34ea88ffa7..d702b518c3f7 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -57,9 +57,10 @@ MAN8= choptest.8c cqtest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
-OPTIONS= PAM "Include pam support" ON \
- NLS "Native Language Support" ON \
- GAWK "Use gawk for scripts" OFF \
+OPTIONS_DEFINE= PAM NLS GAWK
+OPTIONS_DEFAULT=PAM NLS
+NO_OPTIONS_SORT=yes
+GAWK_DESC= Use gawk for scripts
.include <bsd.port.pre.mk>
@@ -69,7 +70,7 @@ CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
.endif
# Want PAM?
-.if defined(WITHOUT_PAM)
+.if empty(PORT_OPTIONS:MPAM)
CONFIGURE_ARGS+=--disable-pam
.endif
@@ -92,12 +93,12 @@ PLIST_SUB+= HYLAFAX_SPOOL=${HYLAFAX_SPOOL}
CONFIGURE_ARGS+=--nointeractive
.endif
-.if defined(WITH_GAWK)
+.if ${PORT_OPTIONS:MGAWK}
BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
CONFIGURE_ARGS+=--with-AWK="${LOCALBASE}/bin/gawk"
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= WITH_NLS=""
.else