aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2018-09-30 03:50:58 +0800
committerdb <db@FreeBSD.org>2018-09-30 03:50:58 +0800
commit76ae2db10d2aab6e4bf433532a29225c0b86fe4d (patch)
treeda0e9698a304611c1f6544c5efe9c22386fe527f /comms
parent44538ebdf1a0559990bc18eca254dcde2f233722 (diff)
downloadfreebsd-ports-gnome-76ae2db10d2aab6e4bf433532a29225c0b86fe4d.tar.gz
freebsd-ports-gnome-76ae2db10d2aab6e4bf433532a29225c0b86fe4d.tar.zst
freebsd-ports-gnome-76ae2db10d2aab6e4bf433532a29225c0b86fe4d.zip
A Linux toolkit for handling signals over the automatric picture
transmission (APT) protocol. ## Intro to Automatic Picture Transmission Automatic picture transmission (APT) is an analog image transmission format developed for use on weather satellites in the 1960s. While only three modern satellites, NOAA 15, NOAA 18, and NOAA 19, transmit on the APT protocol, building a reception station is cheap and simple. The images can be quite high qualitythey natively have a resolution of 4 km/px. It is reasonable to expect at least one good-quality satellite pass (and, thereby, opportunity for image downlink) per day. WWW: https://github.com/rsj56/apitran
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/apitran/Makefile46
-rw-r--r--comms/apitran/distinfo3
-rw-r--r--comms/apitran/pkg-descr13
-rw-r--r--comms/apitran/pkg-plist6
5 files changed, 69 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 88f6a0cc618f..450bd83255b5 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -8,6 +8,7 @@
SUBDIR += aldo
SUBDIR += amtterm
SUBDIR += anyremote
+ SUBDIR += apitran
SUBDIR += aprsd
SUBDIR += atslog
SUBDIR += bfhist
diff --git a/comms/apitran/Makefile b/comms/apitran/Makefile
new file mode 100644
index 000000000000..878a8342b952
--- /dev/null
+++ b/comms/apitran/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= apitran
+PORTVERSION= g20180926
+CATEGORIES= comms astro hamradio python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= Toolkit to handle the automatic picture transmission protocol
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYNUMPY}
+RUN_DEPENDS= sox:audio/sox \
+ display:graphics/ImageMagick
+
+USES= python shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= rsj56
+GH_PROJECT= apitran
+GH_TAGNAME= d209347
+#25379d9b681f434145fde9dbbdb3c5ae3
+#GH_TAGNAME= d20934725379d9b681f434145fde9dbbdb3c5ae3
+
+SHEBANG_FILES= apitran
+USE_PYTHON= autoplist
+
+do-build:
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/apitran ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}
+.for f in NOAA_APT_Frame_Format.gif README.md
+ ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
+.for f in ex_1ch_11025.png ex_2ch_48000.png ex_2ch_48000.wav
+ ${INSTALL_DATA} ${WRKSRC}/Examples/$f ${STAGEDIR}${EXAMPLESDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/comms/apitran/distinfo b/comms/apitran/distinfo
new file mode 100644
index 000000000000..87c32316f077
--- /dev/null
+++ b/comms/apitran/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538226743
+SHA256 (rsj56-apitran-g20180926-d209347_GH0.tar.gz) = 65e2d90dd0077d3a837afaaed98b2f51fe2fceb074e15b9358381a8d61b785b6
+SIZE (rsj56-apitran-g20180926-d209347_GH0.tar.gz) = 57106527
diff --git a/comms/apitran/pkg-descr b/comms/apitran/pkg-descr
new file mode 100644
index 000000000000..e16ff210d766
--- /dev/null
+++ b/comms/apitran/pkg-descr
@@ -0,0 +1,13 @@
+A Linux toolkit for handling signals over the automatric picture
+transmission (APT) protocol.
+
+## Intro to Automatic Picture Transmission
+Automatic picture transmission (APT) is an analog image transmission format
+developed for use on weather satellites in the 1960s. While only three
+modern satellites, NOAA 15, NOAA 18, and NOAA 19, transmit on the APT
+protocol, building a reception station is cheap and simple. The images can
+be quite high qualitythey natively have a resolution of
+4 km/px. It is reasonable to expect at least one good-quality satellite
+pass (and, thereby, opportunity for image downlink) per day.
+
+WWW: https://github.com/rsj56/apitran
diff --git a/comms/apitran/pkg-plist b/comms/apitran/pkg-plist
new file mode 100644
index 000000000000..47902d93b915
--- /dev/null
+++ b/comms/apitran/pkg-plist
@@ -0,0 +1,6 @@
+bin/apitran
+%%DOCSDIR%%/NOAA_APT_Frame_Format.gif
+%%DOCSDIR%%/README.md
+%%EXAMPLESDIR%%/ex_1ch_11025.png
+%%EXAMPLESDIR%%/ex_2ch_48000.png
+%%EXAMPLESDIR%%/ex_2ch_48000.wav