aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-02-04 15:56:26 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-02-04 15:56:26 +0800
commitac0a6992a1913554793d21b09299a079df9380bd (patch)
tree8c7720fbf4cc57f79a2b7635ba61e7968601ab5b /comms
parentcbb0b24890cfff759c98e36419db00ee5ad88cc5 (diff)
downloadfreebsd-ports-gnome-ac0a6992a1913554793d21b09299a079df9380bd.tar.gz
freebsd-ports-gnome-ac0a6992a1913554793d21b09299a079df9380bd.tar.zst
freebsd-ports-gnome-ac0a6992a1913554793d21b09299a079df9380bd.zip
- A function in gnokii happens to use strndup() which is implemented
only in 8.0, so revert it to a simple strdup(). PR: ports/131350 Reported by: ledondo2000 at gmail.com Submitted by: Guido Falsi <mad@madpilot.net> (maintainer)
Diffstat (limited to 'comms')
-rw-r--r--comms/gnokii/Makefile1
-rw-r--r--comms/gnokii/files/patch-gnokii-gnokii.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index e9ca23002ad4..cde2a72811e3 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnokii
PORTVERSION= 0.6.27
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
diff --git a/comms/gnokii/files/patch-gnokii-gnokii.c b/comms/gnokii/files/patch-gnokii-gnokii.c
new file mode 100644
index 000000000000..dd16da5aed4b
--- /dev/null
+++ b/comms/gnokii/files/patch-gnokii-gnokii.c
@@ -0,0 +1,11 @@
+--- gnokii/gnokii.c.orig 2009-02-03 23:23:35.000000000 +0100
++++ gnokii/gnokii.c 2009-02-03 23:24:01.000000000 +0100
+@@ -1082,7 +1082,7 @@
+ else
+ len = strlen(input);
+ if (len > 0)
+- argv[argc++] = strndup(input, len);
++ argv[argc++] = strdup(input);
+ input = tmp;
+ } while (input);
+ argv[argc] = NULL;