aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-10-14 16:01:13 +0800
committertcberner <tcberner@FreeBSD.org>2018-10-14 16:01:13 +0800
commitba96305a9a508696320d5c8513630f4f579d961f (patch)
treea24abebc7b4d4a1a4ecbd6f2f871ffd7f3a282ef /comms
parentc4f589c9f3f52f3ae1ebb35dea0fcc3c8d5c603d (diff)
downloadfreebsd-ports-gnome-ba96305a9a508696320d5c8513630f4f579d961f.tar.gz
freebsd-ports-gnome-ba96305a9a508696320d5c8513630f4f579d961f.tar.zst
freebsd-ports-gnome-ba96305a9a508696320d5c8513630f4f579d961f.zip
qt5: Fix build on GCC based architectures.
PR: 231584 PR: 231677 PR: 231685 PR: 231830 PR: 231955 PR: 231905 PR: 231892 PR: 231684 PR: 231958 PR: 231960 PR: 231818 PR: 231542 PR: 231860 PR: 231681 PR: 231963 PR: 231891 PR: 231966 PR: 231904 PR: 231676 PR: 231819 PR: 231956 PR: 231680 PR: 231957 PR: 231903 PR: 231901 PR: 231667 PR: 231861 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'comms')
-rw-r--r--comms/qt5-sensors/Makefile2
-rw-r--r--comms/qt5-serialport/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/comms/qt5-sensors/Makefile b/comms/qt5-sensors/Makefile
index 28616607e7ae..511812087551 100644
--- a/comms/qt5-sensors/Makefile
+++ b/comms/qt5-sensors/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt sensors module
USE_QT= core qml quick buildtools_build
-USES= qmake:norecursive qt-dist:5,sensors
+USES= compiler:c++11-lang qmake:norecursive qt-dist:5,sensors
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/comms/qt5-serialport/Makefile b/comms/qt5-serialport/Makefile
index 54fdd7e8dfd3..ed28b40448fd 100644
--- a/comms/qt5-serialport/Makefile
+++ b/comms/qt5-serialport/Makefile
@@ -9,7 +9,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt functions to access serial ports
USE_QT= core buildtools_build
-USES= qmake qt-dist:5,serialport
+USES= compiler:c++11-lang libtool qmake qt-dist:5,serialport
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>