aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-01-23 05:56:22 +0800
committerpav <pav@FreeBSD.org>2004-01-23 05:56:22 +0800
commitbaedbcffbfb0c1eac464beb4b9dc4765e4c72120 (patch)
tree89e793cad81f99509703fa9f47b67bad47a85c76 /comms
parentfb94521a937f398767b22d0083afeb2e59034f44 (diff)
downloadfreebsd-ports-gnome-baedbcffbfb0c1eac464beb4b9dc4765e4c72120.tar.gz
freebsd-ports-gnome-baedbcffbfb0c1eac464beb4b9dc4765e4c72120.tar.zst
freebsd-ports-gnome-baedbcffbfb0c1eac464beb4b9dc4765e4c72120.zip
Grig is a graphical front-end to the Ham Radio libraries
written using Gtk+ and Gnome widgets by Alexandru Csete. Part of the grounstation suite, it purpose is to control an amateur radio transceiver from X. It supports any of the transceivers that hamlib supports, including rpc.rigd over the network. However, at present only a subset of the hamlib functions are provided. The groundstation suite comprises Gnome-rig and Gnome-predict and is intended to provide a low-cost amateur radio station with the facilities of a high-end satellite station. WWW: http://groundstation.sourceforge.net/ PR: ports/61729 Submitted by: Matt Dawson <matt@mattsnetwork.co.uk>
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/grig/Makefile30
-rw-r--r--comms/grig/distinfo1
-rw-r--r--comms/grig/pkg-descr14
-rw-r--r--comms/grig/pkg-plist4
5 files changed, 50 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 4648aa0aa2a9..79419ccd4175 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -20,6 +20,7 @@
SUBDIR += gmfsk
SUBDIR += gnokii
SUBDIR += gpredict
+ SUBDIR += grig
SUBDIR += gscmxx
SUBDIR += gsmlib
SUBDIR += hamfax
diff --git a/comms/grig/Makefile b/comms/grig/Makefile
new file mode 100644
index 000000000000..c35eec1fb004
--- /dev/null
+++ b/comms/grig/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: grig
+# Date created: 2004-01-22
+# Whom: Matt Dawson <matt@mattsnetwork.co.uk>
+#
+# $FreeBSD$
+
+PORTNAME= grig
+PORTVERSION= 0.2.2
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= groundstation
+
+MAINTAINER= matt@mattsnetwork.co.uk
+COMMENT= Amateur Radio control front-end
+
+LIB_DEPENDS= hamlib:${PORTSDIR}/comms/hamlib
+
+USE_X_PREFIX= yes
+USE_GNOME= gconf gtk12 gnomecanvas
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS= --disable-nls # nls not supported yet
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|GCONF_LIBS="`|GCONF_LIBS="-lgconf-gtk-1 `|' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/comms/grig/distinfo b/comms/grig/distinfo
new file mode 100644
index 000000000000..5d7be9c77e54
--- /dev/null
+++ b/comms/grig/distinfo
@@ -0,0 +1 @@
+MD5 (grig-0.2.2.tar.gz) = 6d9786c7a5ee5e1f95d2572d3c7ce277
diff --git a/comms/grig/pkg-descr b/comms/grig/pkg-descr
new file mode 100644
index 000000000000..06ccd885dc3b
--- /dev/null
+++ b/comms/grig/pkg-descr
@@ -0,0 +1,14 @@
+Grig is a graphical front-end to the Ham Radio libraries
+written using Gtk+ and Gnome widgets by Alexandru Csete.
+
+Part of the grounstation suite, it purpose is to control
+an amateur radio transceiver from X. It supports any of
+the transceivers that hamlib supports, including rpc.rigd
+over the network. However, at present only a subset of the
+hamlib functions are provided.
+
+The groundstation suite comprises Gnome-rig and Gnome-predict
+and is intended to provide a low-cost amateur radio station
+with the facilities of a high-end satellite station.
+
+WWW: http://groundstation.sourceforge.net/
diff --git a/comms/grig/pkg-plist b/comms/grig/pkg-plist
new file mode 100644
index 000000000000..596867e19693
--- /dev/null
+++ b/comms/grig/pkg-plist
@@ -0,0 +1,4 @@
+bin/grig
+share/pixmaps/grig/digits_normal.xpm
+share/pixmaps/grig/digits_small.xpm
+@dirrm share/pixmaps/grig