aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2008-08-05 02:24:53 +0800
committerdb <db@FreeBSD.org>2008-08-05 02:24:53 +0800
commitc535f580632c7b70ad4bebd72180db21ed6710df (patch)
tree60e4153f5b43a7550f7fd8794f97248b022ec66d /comms
parent2c95432a34b068d5d765b603a969335225603283 (diff)
downloadfreebsd-ports-gnome-c535f580632c7b70ad4bebd72180db21ed6710df.tar.gz
freebsd-ports-gnome-c535f580632c7b70ad4bebd72180db21ed6710df.tar.zst
freebsd-ports-gnome-c535f580632c7b70ad4bebd72180db21ed6710df.zip
This little program helps one with monitoring the beacons of the
International Beacon Project, by continuously showing which beacon is transmitting on which frequency, along with the distance and antenna directions.
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/ibp/Makefile30
-rw-r--r--comms/ibp/distinfo3
-rw-r--r--comms/ibp/files/ibp.118
-rw-r--r--comms/ibp/pkg-descr6
5 files changed, 58 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 31df5c0b8a4a..49b9eecb8a46 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -50,6 +50,7 @@
SUBDIR += hso-kmod
SUBDIR += hylafax
SUBDIR += ib-kmod
+ SUBDIR += ibp
SUBDIR += java-commapi
SUBDIR += java-commapi-freebsd
SUBDIR += jerm
diff --git a/comms/ibp/Makefile b/comms/ibp/Makefile
new file mode 100644
index 000000000000..c5b529e4636f
--- /dev/null
+++ b/comms/ibp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ibp
+# Date created: 3 August 2008
+# Whom: Diane Bruce <db@db.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibp
+PORTVERSION= 0.21
+CATEGORIES= comms hamradio
+MASTER_SITES= http://wwwhome.cs.utwente.nl/~ptdeboer/ham/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= A little program for monitoring amateur radio beacons
+
+USE_XLIB= yes
+USE_IMAKE= yes
+
+PLIST_FILES= bin/ibp
+MAN1= ibp.1
+MANCOMPRESSED= no
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ibp ${PREFIX}/bin/
+ ${INSTALL_MAN} ${FILESDIR}/ibp.1 ${MANPREFIX}/man/man1/ibp.1
+
+.include <bsd.port.mk>
diff --git a/comms/ibp/distinfo b/comms/ibp/distinfo
new file mode 100644
index 000000000000..21b135513bbe
--- /dev/null
+++ b/comms/ibp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ibp-0.21.tgz) = 092ebbca8430707b8df6d9bd9720ebbd
+SHA256 (ibp-0.21.tgz) = b3b118ca83619f0a5605652a0a8c385c77ada3a10321a771e2d19f9f59604abd
+SIZE (ibp-0.21.tgz) = 33536
diff --git a/comms/ibp/files/ibp.1 b/comms/ibp/files/ibp.1
new file mode 100644
index 000000000000..4db4be263402
--- /dev/null
+++ b/comms/ibp/files/ibp.1
@@ -0,0 +1,18 @@
+.Dd August 4, 2008
+.Os Unix
+.Dt ibp 1
+.Sh NAME
+.Nm ibp
+.Nd International beacon program utility
+.Sh SYNOPSIS
+This program displays active beacons complete with an X display.
+.Sh DESCRIPTION
+This little program helps one with monitoring the beacons of the
+International Beacon Project, by continuously showing which beacon is
+transmitting on which frequency, along with the distance and antenna directions.
+.Pp Project Website, Documentation
+The latest version can be found at: http://wwwhome.cs.utwente.nl/~ptdeboer/ham/ibp-0.21.tgz
+.Pp
+Full documentation is at http://wwwhome.cs.utwente.nl/~ptdeboer/ham/ibp.html
+.Sh AUTHORS
+Pieter-Tjerk de Boer, pa3fwm@amsat.org
diff --git a/comms/ibp/pkg-descr b/comms/ibp/pkg-descr
new file mode 100644
index 000000000000..f7d356c056a8
--- /dev/null
+++ b/comms/ibp/pkg-descr
@@ -0,0 +1,6 @@
+This little program helps one with monitoring the beacons of the
+International Beacon Project, by continuously showing which beacon is
+transmitting on which frequency, along with the distance and
+antenna directions.
+
+WWW: http://wwwhome.cs.utwente.nl/~ptdeboer/ham/ibp.html