aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-10-23 00:03:17 +0800
committertijl <tijl@FreeBSD.org>2013-10-23 00:03:17 +0800
commitc5753b4b27f4fcc09243ad62c2d8fcf0fd93aad6 (patch)
tree6204cb23dc92accff826f472e5f6785e66707492 /comms
parent18e3ed9256d702129a1e5b05c5c411f5868c42f4 (diff)
downloadfreebsd-ports-gnome-c5753b4b27f4fcc09243ad62c2d8fcf0fd93aad6.tar.gz
freebsd-ports-gnome-c5753b4b27f4fcc09243ad62c2d8fcf0fd93aad6.tar.zst
freebsd-ports-gnome-c5753b4b27f4fcc09243ad62c2d8fcf0fd93aad6.zip
- Support staging.
- New LIB_DEPENDS syntax. - USES=gmake. - Options helpers. - Make the Requires field private in pkgconfig file.
Diffstat (limited to 'comms')
-rw-r--r--comms/libticalcs2/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/comms/libticalcs2/Makefile b/comms/libticalcs2/Makefile
index 9310356ae6ea..b438ad418006 100644
--- a/comms/libticalcs2/Makefile
+++ b/comms/libticalcs2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libticalcs2
PORTVERSION= 1.1.8
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.17
@@ -10,31 +11,26 @@ COMMENT= TI calculator library
LICENSE= GPLv2
-LIB_DEPENDS= ticables2:${PORTSDIR}/comms/libticables2 \
- ticonv:${PORTSDIR}/converters/libticonv \
- tifiles2:${PORTSDIR}/devel/libtifiles2
+LIB_DEPENDS= libticables2.so:${PORTSDIR}/comms/libticables2 \
+ libticonv.so:${PORTSDIR}/converters/libticonv \
+ libtifiles2.so:${PORTSDIR}/devel/libtifiles2
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's/Requires/&.private/' ${WRKSRC}/ticalcs2.pc.in
.include <bsd.port.mk>