aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2018-06-17 22:42:24 +0800
committerdb <db@FreeBSD.org>2018-06-17 22:42:24 +0800
commitd90e60a9db889217c8d14751b374b57ef70a6e31 (patch)
tree95f4c19ca98079f26e7c67411a53cc57f5cf2042 /comms
parent9457f9b41a49a72f689b2e8f1dccdd6c5adfbe6a (diff)
downloadfreebsd-ports-gnome-d90e60a9db889217c8d14751b374b57ef70a6e31.tar.gz
freebsd-ports-gnome-d90e60a9db889217c8d14751b374b57ef70a6e31.tar.zst
freebsd-ports-gnome-d90e60a9db889217c8d14751b374b57ef70a6e31.zip
Fix typo of locale.setlocal which should be locale.setlocale
Pointy hat to: @shurd
Diffstat (limited to 'comms')
-rw-r--r--comms/quisk/Makefile2
-rw-r--r--comms/quisk/files/patch-quisk.py8
2 files changed, 5 insertions, 5 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index cd8734118573..602a179c84ff 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quisk
PORTVERSION= 4.1.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms hamradio
MASTER_SITES= http://james.ahlstrom.name/quisk/ \
LOCAL/db
diff --git a/comms/quisk/files/patch-quisk.py b/comms/quisk/files/patch-quisk.py
index 0f7b8f6a2f57..12d707e88a1c 100644
--- a/comms/quisk/files/patch-quisk.py
+++ b/comms/quisk/files/patch-quisk.py
@@ -1,12 +1,12 @@
---- quisk.py.orig 2016-11-30 18:26:59 UTC
-+++ quisk.py
-@@ -21,6 +21,13 @@ os.chdir(os.path.normpath(os.path.dirnam
+--- quisk.py.orig 2016-11-30 13:26:59.000000000 -0500
++++ quisk.py 2018-06-17 10:30:03.031192000 -0400
+@@ -21,6 +21,13 @@
if sys.path[0] != "'.'": # Make sure the current working directory is on path
sys.path.insert(0, '.')
+# Hack to ensure unicode is available.
+import locale
-+locale.setlocal(locale.LC_ALL, '')
++locale.setlocale(locale.LC_ALL, '')
+cloc = locale.getdefaultlocale()
+if locale.nl_langinfo(locale.CODESET) != 'UTF-8':
+ locale.setlocale(locale.LC_ALL, (cloc[0], 'UTF-8'))