aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2012-03-19 04:11:43 +0800
committerpav <pav@FreeBSD.org>2012-03-19 04:11:43 +0800
commite1804a1c91cceeeeb05a0ec7e332af12f3c9e0af (patch)
treefec127801e55622c86b248862860dc6ffcc4bb32 /comms
parentc01570adb4d78e16678720700ae91ec7cf732662 (diff)
downloadfreebsd-ports-gnome-e1804a1c91cceeeeb05a0ec7e332af12f3c9e0af.tar.gz
freebsd-ports-gnome-e1804a1c91cceeeeb05a0ec7e332af12f3c9e0af.tar.zst
freebsd-ports-gnome-e1804a1c91cceeeeb05a0ec7e332af12f3c9e0af.zip
- Mark BROKEN on FreeBSD 7: does not compile
openssl_cert.cpp:1296:2: error: #error "Unexpected OpenSSL version; check X509_ATTRIBUTE struct compatibility" openssl_cert.cpp: In function 'int tqsl_getCertificatePrivateKeyType(void*)': openssl_cert.cpp:1053: warning: deprecated conversion from string constant to 'char*' openssl_cert.cpp: In function 'int tqsl_add_bag_attribute(PKCS12_SAFEBAG*, const char*, const std::string&)': openssl_cert.cpp:1271: error: 'asc2uni' was not declared in this scope openssl_cert.cpp: In function 'int tqsl_exportPKCS12File(void*, const char*, const char*)': openssl_cert.cpp:1484: error: conditional expression between distinct pointer types 'int (*)()' and 'int (*)(PKCS7*, unsigned char**)' lacks a cast openssl_cert.cpp:1484: error: invalid conversion from 'int (*)()' to 'void*' openssl_cert.cpp:1484: error: invalid conversion from 'int (*)(PKCS7*, unsigned char**)' to 'void*' openssl_cert.cpp:1484: error: invalid conversion from 'void*' to 'stack_st_OPENSSL_BLOCK*' openssl_cert.cpp:1484: error: initializing argument 1 of 'unsigned char* ASN1_seq_pack(stack_st_OPENSSL_BLOCK*, int (*)(void*, unsigned char**), unsigned char**, int*)' openssl_cert.cpp: In function 'int tqsl_get_bag_attribute(PKCS12_SAFEBAG*, const char*, std::string&)': openssl_cert.cpp:1549: error: 'uni2asc' was not declared in this scope openssl_cert.cpp: At global scope: openssl_cert.cpp:2407: warning: 'int tqsl_cert_get_subject_name_count(X509*)' defined but not used openssl_cert.cpp:2416: warning: 'int tqsl_cert_get_subject_name_index(X509*, int, TQSL_X509_NAME_ITEM*)' defined but not used openssl_cert.cpp:2442: warning: 'int tqsl_cert_get_subject_date(X509*, const char*, tQSL_Date*)' defined but not used *** Error code 1 Reported by: pointyhat Feature safe: yes
Diffstat (limited to 'comms')
-rw-r--r--comms/trustedqsl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/comms/trustedqsl/Makefile b/comms/trustedqsl/Makefile
index 78a5054ea67b..f76abb69cba3 100644
--- a/comms/trustedqsl/Makefile
+++ b/comms/trustedqsl/Makefile
@@ -26,6 +26,12 @@ MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+BROKEN= does not compile on FreeBSD 7.X
+.endif
+
post-patch:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@${REINPLACE_CMD} -e 's|%%INSTALL%%|${INSTALL_PROGRAM}|' \
@@ -64,4 +70,4 @@ post-install:
@${ECHO} before this program will run correctly.
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>