aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2008-08-05 01:08:51 +0800
committerdb <db@FreeBSD.org>2008-08-05 01:08:51 +0800
commit3eccc35f3fb85b5da51be3db8d8ce42d64939489 (patch)
treea2b8855b42c7402b24b20c5be75fafd2cf36a9d2 /comms
parentf5ba1e7895324ddb1be736d0c32586907c0f7e12 (diff)
downloadfreebsd-ports-gnome-3eccc35f3fb85b5da51be3db8d8ce42d64939489.tar.gz
freebsd-ports-gnome-3eccc35f3fb85b5da51be3db8d8ce42d64939489.tar.zst
freebsd-ports-gnome-3eccc35f3fb85b5da51be3db8d8ce42d64939489.zip
- Update to 2.49
- Vendor has fixed lsetad.c so patch no longer necessary.
Diffstat (limited to 'comms')
-rw-r--r--comms/linrad/Makefile4
-rw-r--r--comms/linrad/distinfo6
-rw-r--r--comms/linrad/files/patch-Makefile.in6
-rw-r--r--comms/linrad/files/patch-lsetad.c46
-rw-r--r--comms/linrad/files/patch-lxsys.c10
5 files changed, 13 insertions, 59 deletions
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index fad5f2f66879..121de37dee74 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= linrad
-PORTVERSION= 2.48
+PORTVERSION= 2.49
CATEGORIES= comms hamradio
MASTER_SITES= http://www.nitehawk.com/sm5bsz/linuxdsp/archive/\
http://g7rau.demon.co.uk/sm5bsz/linuxdsp/archive/\
http://www.sm5bsz.com/linuxdsp/archive/
-DISTNAME= lir02-48
+DISTNAME= lir02-49
EXTRACT_SUFX= .tbz
DIST_SUBDIR= ${PORTNAME}
diff --git a/comms/linrad/distinfo b/comms/linrad/distinfo
index df2f0ded88f2..dbb12b2204f6 100644
--- a/comms/linrad/distinfo
+++ b/comms/linrad/distinfo
@@ -1,3 +1,3 @@
-MD5 (linrad/lir02-48.tbz) = ed63828a215a8953be86bcb89bf728bb
-SHA256 (linrad/lir02-48.tbz) = 58f78d992dbfff468c6a72a8dc659a29c73efd574ccb0a180c883bacbac2a288
-SIZE (linrad/lir02-48.tbz) = 506308
+MD5 (linrad/lir02-49.tbz) = a763289dd382f861c0b7a75428dc69b6
+SHA256 (linrad/lir02-49.tbz) = 4d524f59307e1fc40e61f300da484a3fbca74a88b19ab70ce0ced9d1faea8d9c
+SIZE (linrad/lir02-49.tbz) = 511911
diff --git a/comms/linrad/files/patch-Makefile.in b/comms/linrad/files/patch-Makefile.in
index efd89e84ce7a..7ec8d153ebbf 100644
--- a/comms/linrad/files/patch-Makefile.in
+++ b/comms/linrad/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2008-06-25 19:17:06.000000000 -0400
-+++ Makefile.in 2008-07-18 20:57:17.000000000 -0400
+--- Makefile.in.orig 2008-07-29 12:39:53.000000000 -0400
++++ Makefile.in 2008-08-04 11:45:19.000000000 -0400
@@ -4,7 +4,7 @@
# Name the output files *.ol instead of *.o
# so we definitely know it is for Linux.
@@ -21,7 +21,7 @@
CFW = -g -O -DOSNUM=2 -W -Wimplicit -Wreturn-type -Wformat \
-Wunused -Wcomment -Wchar-subscripts -Wshadow -Wuninitialized \
-Wparentheses -Wstrict-prototypes -Werror -ffast-math \
-@@ -682,7 +679,7 @@
+@@ -683,7 +680,7 @@
diff --git a/comms/linrad/files/patch-lsetad.c b/comms/linrad/files/patch-lsetad.c
deleted file mode 100644
index 29b2111bcc44..000000000000
--- a/comms/linrad/files/patch-lsetad.c
+++ /dev/null
@@ -1,46 +0,0 @@
---- lsetad.c.orig 2008-07-18 20:59:42.000000000 -0400
-+++ lsetad.c 2008-07-18 21:02:51.000000000 -0400
-@@ -1234,8 +1234,10 @@
- {
- unsigned int val;
- int ad_bytes_per_sample;
-+#ifdef ALSA_PRESENT
- static snd_pcm_format_t format;
- snd_pcm_hw_params_t *hw_ad_params;
-+#endif
- char ss[sizeof(DEVNAME_BASE)+2];
- int i, j, err, frag, resample;
- float t1;
-@@ -1480,8 +1482,10 @@
- {
- char *buf;
- unsigned int val;
-+#ifdef ALSA_PRESENT
- static snd_pcm_format_t format;
- snd_pcm_hw_params_t *hw_da_params;
-+#endif
- int i, j, dir, err, frag, resample;
- char ss[sizeof(DEVNAME_BASE)+2];
- float t1;
-@@ -1815,8 +1819,10 @@
- {
- int ad_bytes_per_sample;
- unsigned int val;
-+#ifdef ALSA_PRESENT
- static snd_pcm_format_t format;
- snd_pcm_hw_params_t *hw_ad_params;
-+#endif
- char ss[sizeof(DEVNAME_BASE)+2];
- float t1;
- int i, j, err, frag, resample;
-@@ -2123,8 +2129,10 @@
- void open_rx_sndout(void)
- {
- unsigned int val;
-+#ifdef ALSA_PRESENT
- static snd_pcm_format_t format;
- snd_pcm_hw_params_t *hw_da_params;
-+#endif
- char ss[sizeof(DEVNAME_BASE)+2];
- int i, j, dir, err, resample;
- int old_disksave_flag, old_mode, old_chan, old_speed;
diff --git a/comms/linrad/files/patch-lxsys.c b/comms/linrad/files/patch-lxsys.c
index 060fca6ecaf2..911e700875bd 100644
--- a/comms/linrad/files/patch-lxsys.c
+++ b/comms/linrad/files/patch-lxsys.c
@@ -1,5 +1,5 @@
---- lxsys.c.orig 2008-06-25 19:17:06.000000000 -0400
-+++ lxsys.c 2008-07-18 20:15:10.000000000 -0400
+--- lxsys.c.orig 2008-07-29 12:39:53.000000000 -0400
++++ lxsys.c 2008-08-04 11:46:11.000000000 -0400
@@ -1,12 +1,14 @@
-
-#include <sys/io.h>
@@ -28,7 +28,7 @@
void perseus_input(void){};
-@@ -190,15 +193,13 @@
+@@ -220,15 +223,13 @@
int lir_parport_permission(void)
{
@@ -48,7 +48,7 @@
}
if(i != 0)
{
-@@ -355,11 +356,9 @@
+@@ -385,11 +386,9 @@
int i;
if(ui.parport < 0x400-4)
{
@@ -63,7 +63,7 @@
}
if(i!=0)lirerr(764921);
i=1000;
-@@ -372,11 +371,9 @@
+@@ -402,11 +401,9 @@
int i;
if(ui.parport < 0x400-4)
{