aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2020-01-26 04:19:38 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2020-01-27 02:35:50 +0800
commit4d94f2a810a886192bd8bd24ae6d745f1bfa4ec6 (patch)
tree21212b9eaa50c1264ec485f41d0b6fb7428ef00b /comms
parent668e24b586ef7584355af2492ea5d16044ff51c3 (diff)
downloadfreebsd-ports-gnome-4d94f2a810a886192bd8bd24ae6d745f1bfa4ec6.tar.gz
freebsd-ports-gnome-4d94f2a810a886192bd8bd24ae6d745f1bfa4ec6.tar.zst
freebsd-ports-gnome-4d94f2a810a886192bd8bd24ae6d745f1bfa4ec6.zip
misc/qtchooser: do not create unnecessary wrappers
misc/qtchooser provides a wrapper binary bin/qtchooser, that when called with name foo, will lauch the corresponding binary from lib/qt${current_qt_version}/bin/foo. Previously qtchooser would install a list of 30-ish symlinks to itself automatically. Now we switch this around. qt-dist ports that define QT_BINARIES will now have a @postexec and @postunexec entry added to their plist to run the shell-script update-qtchooser-wrapper (installed by qtchooser). update-qtchooser-wrapper removes all symlinks to bin/qtcreator that have no corresponding binary in lib/qt*/bin, and readds links that are missing. Exp-run by: antoine PR: 242905 PR: 243443 Reported by: grarpamp@gmail.com Reviewed by: adridg Differential Revision: https://reviews.freebsd.org/D22991
Diffstat (limited to 'comms')
-rw-r--r--comms/qt5-serialbus/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/comms/qt5-serialbus/Makefile b/comms/qt5-serialbus/Makefile
index aeccbf4933ae..c95fda8eb6d3 100644
--- a/comms/qt5-serialbus/Makefile
+++ b/comms/qt5-serialbus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= serialbus
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
@@ -11,5 +12,6 @@ COMMENT= Qt functions to access industrial bus systems
USES= compiler:c++11-lib qmake qt-dist:5,serialbus
USE_QT= core network serialport buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+QT_BINARIES= yes
.include <bsd.port.mk>