aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-11-30 00:52:05 +0800
committerriggs <riggs@FreeBSD.org>2015-11-30 00:52:05 +0800
commit717972e6a0a6f8ccecad9d9ade1e68c32e0d27ef (patch)
tree872763b88f021a0d2f6ff99c8c3b609438581b47 /comms
parentbb4c46b2d1bcbf44b22c51c3773959942e7018ad (diff)
downloadfreebsd-ports-gnome-717972e6a0a6f8ccecad9d9ade1e68c32e0d27ef.tar.gz
freebsd-ports-gnome-717972e6a0a6f8ccecad9d9ade1e68c32e0d27ef.tar.zst
freebsd-ports-gnome-717972e6a0a6f8ccecad9d9ade1e68c32e0d27ef.zip
Fix runtime segfault due to uninitialised variable, bump PORTREVISION
While on it: - Pet portlint: regenerate patches using 'make makepatch' - Add LICENSE PR: 204845 Submitted by: yama@jasper.co.jp MFH: 2015Q4 (ports-secteam fix blanket)
Diffstat (limited to 'comms')
-rw-r--r--comms/efax/Makefile5
-rw-r--r--comms/efax/files/patch-Makefile (renamed from comms/efax/files/patch-src_Makefile)6
-rw-r--r--comms/efax/files/patch-efaxmsg.c36
-rw-r--r--comms/efax/files/patch-fax (renamed from comms/efax/files/patch-src_fax)16
4 files changed, 51 insertions, 12 deletions
diff --git a/comms/efax/Makefile b/comms/efax/Makefile
index 5db25aa6ac23..225659709c0a 100644
--- a/comms/efax/Makefile
+++ b/comms/efax/Makefile
@@ -3,13 +3,16 @@
PORTNAME= efax-0.9a
PORTVERSION= 001114a7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= comms
MASTER_SITES= http://shino.pos.to/linux/
MAINTAINER= ports@FreeBSD.org
COMMENT= Fax send/receive program
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
RUN_DEPENDS=xloadimage:${PORTSDIR}/x11/xloadimage
DOCSDIR= ${PREFIX}/share/doc/efax
diff --git a/comms/efax/files/patch-src_Makefile b/comms/efax/files/patch-Makefile
index 30d6d5985b11..5a3c9e9f8084 100644
--- a/comms/efax/files/patch-src_Makefile
+++ b/comms/efax/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Wed Jun 28 19:01:22 2000
-+++ Makefile Sun Oct 20 03:06:13 2002
+--- Makefile.orig 2000-06-29 02:01:22 UTC
++++ Makefile
@@ -3,20 +3,17 @@
# Change the following to the name of your ANSI C compiler
# (normally gcc).
@@ -24,7 +24,7 @@
.c.o:
$(CC) $(CFLAGS) -c $<
-@@ -32,11 +29,9 @@
+@@ -32,11 +29,9 @@ efix: efix.o efaxlib.o efaxmsg.o
strip efix
install:
diff --git a/comms/efax/files/patch-efaxmsg.c b/comms/efax/files/patch-efaxmsg.c
new file mode 100644
index 000000000000..1ae052080897
--- /dev/null
+++ b/comms/efax/files/patch-efaxmsg.c
@@ -0,0 +1,36 @@
+--- efaxmsg.c.orig 1999-03-20 04:38:20 UTC
++++ efaxmsg.c
+@@ -98,9 +98,6 @@ int msg ( char *fmt, ... )
+ int err=0, i, flags=0 ;
+ char *p ;
+
+- va_list ap ;
+- va_start ( ap, fmt ) ;
+-
+ if ( ! init ) {
+ logfile[0] = stderr ;
+ logfile[1] = stdout ;
+@@ -112,6 +109,9 @@ int msg ( char *fmt, ... )
+
+ for ( i=0 ; i<NLOG ; i++ ) {
+
++ va_list ap ;
++ va_start ( ap, fmt ) ;
++
+ for ( p=fmt ; *p ; p++ ) {
+ switch ( *p ) {
+ case ' ': p++ ; goto print ;
+@@ -148,11 +148,11 @@ int msg ( char *fmt, ... )
+ if ( ! ( flags & NOFLSH ) ) fflush ( logfile[i] ) ;
+
+ }
++
++ va_end ( ap ) ;
+
+ }
+
+- va_end ( ap ) ;
+-
+ return err ;
+ }
+
diff --git a/comms/efax/files/patch-src_fax b/comms/efax/files/patch-fax
index 497c20070088..dc7920ac773d 100644
--- a/comms/efax/files/patch-src_fax
+++ b/comms/efax/files/patch-fax
@@ -1,6 +1,6 @@
---- fax.orig Sat May 11 12:39:37 2002
-+++ fax Sat May 11 13:42:33 2002
-@@ -24,7 +24,7 @@
+--- fax.orig 2002-02-02 13:14:08 UTC
++++ fax
+@@ -24,7 +24,7 @@ echo "fax: version 0.9001114a7 (30 Jan 2
# - do not put spaces before or after the equal (=) signs.
#
# - variables can also be set on the command line, for example:
@@ -9,7 +9,7 @@
# or in a configuration file (see CONFIGFILES below)
#
-@@ -36,16 +36,16 @@
+@@ -36,16 +36,16 @@ EFAX=efax
EFIX=efix
# The device to which the fax modem is connected (e.g. ttya for
@@ -30,7 +30,7 @@
# Your fax number in international format, 20 characters maximum.
# Use only digits, spaces, and the "+" character.
-@@ -98,7 +98,8 @@
+@@ -98,7 +98,8 @@ DIALSUFFIX=""
# conventions. Protect with single quotes for delayed evaluation.
# Add a leading '#' to the file name to use binary format.
@@ -40,7 +40,7 @@
# LOCK='-x /usr/spool/uucp/LCK..$DEV' # older systems
# LOCK='-x /var/lock/LCK..$DEV -x /var/spool/uucp/LCK..$DEV' # both
# LOCK='-x #/usr/spool/uucp/LCK..$DEV' # binary format
-@@ -124,7 +125,7 @@
+@@ -124,7 +125,7 @@ LOCK='-x /var/lock/LCK..$DEV' # moder
# out if you don't need to use config files. Warning: any type of
# shell command in these files will be executed.
@@ -49,7 +49,7 @@
# A command that will generate unique names for logs and received
# files. 'date +%m%d%H%M%S' works on most systems. Protect with
-@@ -421,9 +422,9 @@
+@@ -421,9 +422,9 @@ VCMD="exec $FONE %d"
# efax even if a previous process (e.g. login) has changed it.
# Comment out if you don't need to reset device ownership.
@@ -62,7 +62,7 @@
# Regular expression for efax exit codes in log files that will
# *not* be saved. For example, use [145] to ignore exits due to
-@@ -1101,7 +1102,7 @@
+@@ -1101,7 +1102,7 @@ cat 1>&2 <<EOF
if given no arguments, answers the phone and receives a fax.