aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2008-08-27 07:38:27 +0800
committerdb <db@FreeBSD.org>2008-08-27 07:38:27 +0800
commitbe96c8a34fd6a05eef50135c52a1956ffba3f40a (patch)
tree5a8f27731dff2b46b36c79324ee1a46f16229a70 /comms
parent6b87b0efe3c6c437486a6c8be0868092e3f62392 (diff)
downloadfreebsd-ports-gnome-be96c8a34fd6a05eef50135c52a1956ffba3f40a.tar.gz
freebsd-ports-gnome-be96c8a34fd6a05eef50135c52a1956ffba3f40a.tar.zst
freebsd-ports-gnome-be96c8a34fd6a05eef50135c52a1956ffba3f40a.zip
- Use BUILD_DEPENDS to ensure the port has fltk-threads not fltk.
- USE_GCC 4.2+ as portlint suggests for 6.x builds.
Diffstat (limited to 'comms')
-rw-r--r--comms/fldigi/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 8909abe36e57..d62f50754677 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -15,9 +15,9 @@ MASTER_SITE_SUBDIR= db
MAINTAINER= db@FreeBSD.org
COMMENT= Digital decoder for psk, cw, psk31, olivia
-BUILD_DEPENDS= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2
-LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk-threads \
- hamlib:${PORTSDIR}/comms/hamlib \
+BUILD_DEPENDS= ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2 \
+ fltk-threads>=0:${PORTSDIR}/x11-toolkits/fltk-threads
+LIB_DEPENDS= hamlib:${PORTSDIR}/comms/hamlib \
sndfile:${PORTSDIR}/audio/libsndfile \
boost_wave:${PORTSDIR}/devel/boost \
pulse:${PORTSDIR}/audio/pulseaudio
@@ -28,7 +28,7 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" && ${OSVERSION} < 700000
-USE_GCC= 4.1
+USE_GCC= 4.2+
.endif
.if ${ARCH} == "sparc64"
BROKEN= Fails to install