aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorshurd <shurd@FreeBSD.org>2014-12-08 19:20:39 +0800
committershurd <shurd@FreeBSD.org>2014-12-08 19:20:39 +0800
commit0515aaaa339dc7577d2990eb19ea4c60c29652f4 (patch)
tree72d4748fb15a4f1a595f7d215383bc5053be1d1e /comms
parent60bbc5b7db30177643ce277fea8db485bcff41d1 (diff)
downloadfreebsd-ports-gnome-0515aaaa339dc7577d2990eb19ea4c60c29652f4.tar.gz
freebsd-ports-gnome-0515aaaa339dc7577d2990eb19ea4c60c29652f4.tar.zst
freebsd-ports-gnome-0515aaaa339dc7577d2990eb19ea4c60c29652f4.zip
Update to 4.02 and fix build errors with clang 5
Linrad-04.02 comes with many improvements. The first FFT can now run in parallel in up to 6 separate threads. More efficient FFT implementations are available for some hardware architectures. The converter option is corrected. Several bug corrections.
Diffstat (limited to 'comms')
-rw-r--r--comms/linrad/Makefile5
-rw-r--r--comms/linrad/distinfo4
-rw-r--r--comms/linrad/files/patch-Makefile.in102
-rw-r--r--comms/linrad/files/patch-afedri.c10
-rw-r--r--comms/linrad/files/patch-configure17
-rw-r--r--comms/linrad/files/patch-elektor.c11
-rw-r--r--comms/linrad/files/patch-loadusb.h10
-rw-r--r--comms/linrad/files/patch-lxsys.c13
-rw-r--r--comms/linrad/files/patch-pcie9842.c10
-rw-r--r--comms/linrad/files/patch-si570.c11
-rw-r--r--comms/linrad/files/patch-usb2lpd.c11
-rw-r--r--comms/linrad/files/patch-wse_sdrxx.c26
12 files changed, 126 insertions, 104 deletions
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index 51f39e11a1df..fc49241c8d97 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= linrad
-PORTVERSION= 4.00
-PORTREVISION= 1
+PORTVERSION= 4.02
CATEGORIES= comms hamradio
MASTER_SITES= http://www.nitehawk.com/sm5bsz/linuxdsp/archive/\
http://g7rau.demon.co.uk/sm5bsz/linuxdsp/archive/\
http://www.sm5bsz.com/linuxdsp/archive/
-DISTNAME= lir04-00
+DISTNAME= lir04-02
EXTRACT_SUFX= .tbz
MAINTAINER= hamradio@FreeBSD.org
diff --git a/comms/linrad/distinfo b/comms/linrad/distinfo
index a4c439c4c3cd..d861a47d1416 100644
--- a/comms/linrad/distinfo
+++ b/comms/linrad/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lir04-00.tbz) = cd9fe11a51ff95daea28c053b6f9f7939cfbcb42c828cbc48e59c0a901b1764a
-SIZE (lir04-00.tbz) = 887240
+SHA256 (lir04-02.tbz) = f9fe2bad9dc255309b8150afeb6c917bf297bb1ca4c7f49c281a60e64fb346fa
+SIZE (lir04-02.tbz) = 880754
diff --git a/comms/linrad/files/patch-Makefile.in b/comms/linrad/files/patch-Makefile.in
index 285598850b4f..5308d940e5bb 100644
--- a/comms/linrad/files/patch-Makefile.in
+++ b/comms/linrad/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig 2014-03-20 18:05:17.000000000 -0700
-+++ Makefile.in 2014-06-27 18:16:06.000000000 -0700
+--- Makefile.in.orig 2014-11-04 02:25:00.000000000 -0800
++++ Makefile.in 2014-12-08 03:03:40.000000000 -0800
@@ -23,7 +23,7 @@
#
# ----------- Compilers ----------------
@@ -13,71 +13,85 @@
# (*.o files can be present by mistake)
# Always use the same flags.
# -Wconversion -Wno-sign-conversion -Wunreachable-code
--CFL = -g -O2 -DOSNUM=1 -DMEMREF_T=int @X11_32_INC@ -W -Wall \
-+CFL = -O2 -DOSNUM=1 -DMEMREF_T=int @X11_32_INC@ \
- @PORTAUDIO32_INC@ -DCPU=@CPU@ -DLIBBLADERF_PRESENT=@LIBBLADERF32_OK@ \
- -DSHM_INSTALLED=@LIBXEXT32_OK@ -DPERSEUSLIB_PRESENT=@PERSEUS32_OK@ -Wimplicit \
- -DALSA_PRESENT=@ALSA32_OK@ -DPA_OK=@PORTAUDIO32_OK@ -DREALT=@PA_REALT32@ \
-@@ -51,9 +51,7 @@
- -DLIBUSB1_PRESENT=@LIBUSB1_32_OK@ -DLIBFTDI_PRESENT=@LIBFTDI32_OK@ @DARWIN@ \
- -DLIBUDEV_PRESENT=@LIBUDEV_32_OK@ -DPCIE9842_PRESENT=@LIBWD_DASK_32_OK@ \
- -DLIBMIRISDR_PRESENT=@LIBMIRISDR32_OK@ -DSERVER=@MAKE_SERVER@ \
---Wreturn-type -Wformat @M32@ -Wunused -Wcomment -Wchar-subscripts -Wshadow \
---Wuninitialized -Wparentheses -Wstrict-prototypes -Werror -ffast-math \
---Wundef -fomit-frame-pointer -c -o
-+@M32@ -ffast-math -fomit-frame-pointer -c -o
+-CFL = -g -O2 -DOSNUM=1 -DMEMREF_T=int @X11_32_INC@ -W -Wall -DCPU=@CPU@ \
++CFL = -O2 -DOSNUM=1 -DMEMREF_T=int @X11_32_INC@ -W -Wall -DCPU=@CPU@ \
+ -DSHM_INSTALLED=@LIBXEXT32_OK@ -Wimplicit \
+ -DALSA_PRESENT=@ALSA32_OK@ -DIA64=0 \
+ @DARWIN@ -DLIBUDEV_PRESENT=@LIBUDEV_32_OK@ -DSERVER=@MAKE_SERVER@ \
+@@ -50,7 +50,7 @@
+ -Wuninitialized -Wparentheses -Wstrict-prototypes -Werror -ffast-math \
+ -Wundef -fomit-frame-pointer -c -o
- CFLN = -g -O2 -DOSNUM=1 -DMEMREF_T=int @X11_32_INC@ -W -Wall \
- @PORTAUDIO32_INC@ -DCPU=@CPU@ -DLIBBLADERF_PRESENT=@LIBBLADERF32_OK@ \
-@@ -1217,7 +1215,7 @@
- @LIBWD_DASK_32_LD@ \
- @LIBBLADERF32_LD@ \
- @LIBMIRISDR32_LD@ \
+-CFLN = -g -O2 -DOSNUM=1 -DMEMREF_T=int @X11_32_INC@ -W -Wall \
++CFLN = -O2 -DOSNUM=1 -DMEMREF_T=int @X11_32_INC@ -W -Wall \
+ -DCPU=@CPU@ -DSHM_INSTALLED=@LIBXEXT32_OK@ -Wimplicit \
+ -DALSA_PRESENT=@ALSA32_OK@ -DIA64=0 \
+ @DARWIN@ -DLIBUDEV_PRESENT=@LIBUDEV_32_OK@ -DSERVER=@MAKE_SERVER@ \
+@@ -58,13 +58,13 @@
+ -Wuninitialized -Wparentheses -Wstrict-prototypes -Werror -ffast-math \
+ -Wundef -fomit-frame-pointer -c -o
+
+-CFW = -g -O2 -DOSNUM=2 -DMEMREF_T=int -W -Wall -Wimplicit -DIA64=0 \
++CFW = -O2 -DOSNUM=2 -DMEMREF_T=int -W -Wall -Wimplicit -DIA64=0 \
+ -DLIBUDEV_PRESENT=1 -DCPU=CPU_INTEL -DSERVER=@MAKE_SERVER@ \
+ @M32@ -Wreturn-type -Wformat -Wunused -Wcomment -Wchar-subscripts \
+ -Wshadow -Wuninitialized -Wparentheses -Wstrict-prototypes -Werror \
+ -ffast-math -Wundef -fomit-frame-pointer -c -o
+
+-CFL64 = -g -O2 -DOSNUM=1 -DMEMREF_T='long int' @X11_64_INC@ -W -Wall \
++CFL64 = -O2 -DOSNUM=1 -DMEMREF_T='long int' @X11_64_INC@ -W -Wall \
+ -DCPU=@CPU@ -DSHM_INSTALLED=@LIBXEXT64_OK@ -DALSA_PRESENT=@ALSA64_OK@ \
+ -DIA64=1 @DARWIN@ -DLIBUDEV_PRESENT=@LIBUDEV_64_OK@ -DSERVER=@MAKE_SERVER@ \
+ -Wimplicit -Wreturn-type -Wformat -m64 -Wunused -Wcomment \
+@@ -1040,7 +1040,7 @@
+ @SVGA32_LD@ \
+ @SVGAGL32_LD@ \
+ @LIBUDEV_32_LD@ \
--lpthread @LIBRT@ -lm -ldl
-+-lpthread @LIBRT@ -lm
++-lpthread @LIBRT@ -lm
@echo " "
@echo "You may want to disable pulseaudio in Ubuntu with this command:"
-@@ -1324,7 +1322,7 @@
- @LIBWD_DASK_32_LD@ \
- @LIBBLADERF32_LD@ \
- @LIBMIRISDR32_LD@ \
+@@ -1137,7 +1137,7 @@
+ @X11_32_LD@ \
+ @ALSA32_LD@ \
+ @LIBUDEV_32_LD@ \
--lpthread @LIBRT@ -lm -ldl
+-lpthread @LIBRT@ -lm
@echo " "
@echo "You may want to disable pulseaudio in Ubuntu with this command:"
-@@ -1407,7 +1405,7 @@
- @LIBWD_DASK_32_LD@ \
- @LIBBLADERF32_LD@ \
- @LIBMIRISDR32_LD@ \
+@@ -1210,7 +1210,7 @@
+ @SVGA32_LD@ \
+ @SVGAGL32_LD@ \
+ @LIBUDEV_32_LD@ \
--lpthread @LIBRT@ -lm -ldl
-+-lpthread @LIBRT@ -lm
++-lpthread @LIBRT@ -lm
@echo " "
@echo "You may want to disable pulseaudio in Ubuntu with this command:"
-@@ -1726,7 +1724,7 @@
- @LIBWD_DASK_64_LD@ \
- @LIBBLADERF64_LD@ \
- @LIBMIRISDR64_LD@ \
+@@ -1527,7 +1527,7 @@
+ @SVGA64_LD@ \
+ @SVGAGL64_LD@ \
+ @LIBUDEV_64_LD@ \
--lpthread @LIBRT@ -lm -ldl
-+-lpthread @LIBRT@ -lm
++-lpthread @LIBRT@ -lm
@echo " "
@echo "You may want to disable pulseaudio in Ubuntu with this command:"
-@@ -1821,7 +1819,7 @@
- @LIBWD_DASK_64_LD@ \
- @LIBBLADERF64_LD@ \
- @LIBMIRISDR64_LD@ \
+@@ -1612,7 +1612,7 @@
+ @ALSA64_LD@ \
+ @X11_64_LD@ \
+ @LIBUDEV_64_LD@ \
--lpthread @LIBRT@ -lm -ldl
+-lpthread @LIBRT@ -lm
@echo " "
@echo "You may want to disable pulseaudio in Ubuntu with this command:"
-@@ -1905,7 +1903,7 @@
- @LIBWD_DASK_64_LD@ \
- @LIBBLADERF64_LD@ \
- @LIBMIRISDR64_LD@ \
+@@ -1686,7 +1686,7 @@
+ @SVGA64_LD@ \
+ @SVGAGL64_LD@ \
+ @LIBUDEV_64_LD@ \
--lpthread @LIBRT@ -lm -ldl
+-lpthread @LIBRT@ -lm
diff --git a/comms/linrad/files/patch-afedri.c b/comms/linrad/files/patch-afedri.c
deleted file mode 100644
index d9a4d43ebb8e..000000000000
--- a/comms/linrad/files/patch-afedri.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- afedri.c.orig 2014-06-27 17:35:06.000000000 -0700
-+++ afedri.c 2014-06-27 17:35:14.000000000 -0700
-@@ -22,7 +22,6 @@
-
-
- #include <stdio.h>
--#include <malloc.h>
- #include <wchar.h>
- #include <string.h>
- #include <stdlib.h>
diff --git a/comms/linrad/files/patch-configure b/comms/linrad/files/patch-configure
index 2a09cc92cc79..9a874ff700df 100644
--- a/comms/linrad/files/patch-configure
+++ b/comms/linrad/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2014-03-21 16:56:05.000000000 -0700
-+++ configure 2014-06-27 20:23:16.000000000 -0700
-@@ -1883,11 +1883,6 @@
+--- configure.orig 2014-11-04 02:25:00.000000000 -0800
++++ configure 2014-12-08 03:06:39.000000000 -0800
+@@ -1832,11 +1832,6 @@
ELF32=""
ELF64=""
if test ${OS} != "Darwin"; then
@@ -12,7 +12,7 @@
ELF64="-felf64"
LIBEXT="so"
S_OS_TYPE="OS_LINUX"
-@@ -1904,7 +1899,9 @@
+@@ -1853,7 +1848,9 @@
fi
# Find out whether we have gcc
@@ -23,12 +23,3 @@
# Extract the first word of "${CC} ", so it can be a program name with args.
set dummy ${CC} ; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-@@ -4318,7 +4315,7 @@
- # Look for the libusb-1.0 package that we need for Perseus.
- LIBUSB1_32_OK="0"
- LIBUSB1_64_OK="0"
--X=`./libfind1 libusb-1.0.${LIBEXT}`
-+X=`./libfind1 libusb.${LIBEXT}`
- LIBUSB1_32_INC=`./libfind2 1 "$X"`
- LIBUSB1_64_INC=`./libfind2 2 "$X"`
- Y=`./libfind2 0 "$X"`
diff --git a/comms/linrad/files/patch-elektor.c b/comms/linrad/files/patch-elektor.c
new file mode 100644
index 000000000000..5f94bcac7d6e
--- /dev/null
+++ b/comms/linrad/files/patch-elektor.c
@@ -0,0 +1,11 @@
+--- elektor.c.orig 2014-12-08 03:00:20.000000000 -0800
++++ elektor.c 2014-12-08 03:00:29.000000000 -0800
+@@ -1020,7 +1020,7 @@
+
+ //fprintf( stderr,"update-freq() cntrfreq=%f, hwfreq=%f\n",fg.passband_center,hwfreq);
+ // This routine is called from the screen thread.
+- if ( abs(old_hwfreq-hwfreq) > 0.001 )
++ if ( fabs(old_hwfreq-hwfreq) > 0.001 )
+ { Setup_Preselector();
+ old_hwfreq = hwfreq;
+ show_elektor_parms();
diff --git a/comms/linrad/files/patch-loadusb.h b/comms/linrad/files/patch-loadusb.h
new file mode 100644
index 000000000000..b7c73e2e87f6
--- /dev/null
+++ b/comms/linrad/files/patch-loadusb.h
@@ -0,0 +1,10 @@
+--- loadusb.h.orig 2014-12-08 03:09:37.000000000 -0800
++++ loadusb.h 2014-12-08 03:10:07.000000000 -0800
+@@ -30,6 +30,7 @@
+
+ #if OSNUM == OSNUM_LINUX
+ #include <limits.h>
++#include <sys/time.h>
+ #define LIBUSB_CALL
+ #endif
+
diff --git a/comms/linrad/files/patch-lxsys.c b/comms/linrad/files/patch-lxsys.c
new file mode 100644
index 000000000000..d613242252df
--- /dev/null
+++ b/comms/linrad/files/patch-lxsys.c
@@ -0,0 +1,13 @@
+--- lxsys.c.orig 2014-12-08 03:10:46.000000000 -0800
++++ lxsys.c 2014-12-08 03:11:39.000000000 -0800
+@@ -120,9 +120,9 @@
+ char *fsse=" sse";
+ char *fht=" ht";
+ char *fprocessor="processor";
++int no_of_ht;
+ #endif
+ int xxprint;
+-int no_of_ht;
+ // If there is no mmx, do not use simd either.
+ tickspersec = sysconf(_SC_CLK_TCK);
+ xxprint=0;
diff --git a/comms/linrad/files/patch-pcie9842.c b/comms/linrad/files/patch-pcie9842.c
deleted file mode 100644
index 1e465813d194..000000000000
--- a/comms/linrad/files/patch-pcie9842.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- pcie9842.c.orig 2014-06-27 17:35:42.000000000 -0700
-+++ pcie9842.c 2014-06-27 17:35:49.000000000 -0700
-@@ -2,7 +2,6 @@
- #if PCIE9842_PRESENT == 1
- #include <stdio.h>
- #include <stdlib.h>
--#include <malloc.h>
- #include <unistd.h>
- #include <pthread.h>
- #include <string.h>
diff --git a/comms/linrad/files/patch-si570.c b/comms/linrad/files/patch-si570.c
deleted file mode 100644
index d391e47b053a..000000000000
--- a/comms/linrad/files/patch-si570.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- si570.c.orig 2014-06-27 18:12:23.000000000 -0700
-+++ si570.c 2014-06-27 18:12:39.000000000 -0700
-@@ -376,7 +376,7 @@
- #if LIBUSB_VERSION == 1
-
-
--#include <libusb-1.0/libusb.h>
-+#include <libusb.h>
-
-
- libusb_device_handle *global_si570usb_handle = NULL;
diff --git a/comms/linrad/files/patch-usb2lpd.c b/comms/linrad/files/patch-usb2lpd.c
deleted file mode 100644
index 3ed6fbae5fbf..000000000000
--- a/comms/linrad/files/patch-usb2lpd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- usb2lpt.c.orig 2014-06-27 18:13:15.000000000 -0700
-+++ usb2lpt.c 2014-06-27 18:13:45.000000000 -0700
-@@ -47,7 +47,7 @@
- #if LIBUSB_VERSION == 1
-
-
--#include <libusb-1.0/libusb.h>
-+#include <libusb.h>
- #else
- #include <usb.h>
- #include "usbdefs.h"
diff --git a/comms/linrad/files/patch-wse_sdrxx.c b/comms/linrad/files/patch-wse_sdrxx.c
new file mode 100644
index 000000000000..89a53df10738
--- /dev/null
+++ b/comms/linrad/files/patch-wse_sdrxx.c
@@ -0,0 +1,26 @@
+--- wse_sdrxx.c.orig 2014-11-04 02:25:00.000000000 -0800
++++ wse_sdrxx.c 2014-12-08 03:15:31.000000000 -0800
+@@ -219,9 +219,9 @@
+ m=10000;
+ for(i=0; i<no_of_rtl2832_gains; i++)
+ {
+- if(fabs(fg.gain-(int)rint(0.1*rtl2832_gains[i])) < m)
++ if(abs(fg.gain-(int)rint(0.1*rtl2832_gains[i])) < m)
+ {
+- m=fabs(fg.gain-(int)rint(0.1*rtl2832_gains[i]));
++ m=abs(fg.gain-(int)rint(0.1*rtl2832_gains[i]));
+ j=i;
+ }
+ }
+@@ -265,9 +265,9 @@
+ m=10000;
+ for(i=0; i<no_of_mirics_gains; i++)
+ {
+- if(fabs(fg.gain-mirics_gains[i]) < m)
++ if(abs(fg.gain-mirics_gains[i]) < m)
+ {
+- m=fabs(fg.gain-mirics_gains[i]);
++ m=abs(fg.gain-mirics_gains[i]);
+ j=i;
+ }
+ }