aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-05-05 19:35:57 +0800
committerjbeich <jbeich@FreeBSD.org>2015-05-05 19:35:57 +0800
commit7643188f95287e6d6ac7a2408aebcb530c295ed9 (patch)
treedef40ba664ed6093a1b4243898d84128e0cd430c /comms
parent2fe63a96bb7cbc911ab8495075afeedcde9fc90e (diff)
downloadfreebsd-ports-gnome-7643188f95287e6d6ac7a2408aebcb530c295ed9.tar.gz
freebsd-ports-gnome-7643188f95287e6d6ac7a2408aebcb530c295ed9.tar.zst
freebsd-ports-gnome-7643188f95287e6d6ac7a2408aebcb530c295ed9.zip
comms/usbmuxd: unbreak build on 10.2R and 11.0C
Try to autodetect ppoll(2) instead of hardcoding the list of platforms lacking it thus using fallback. GitHub: libimobiledevice/usbmuxd#36 PR: 199545 Reported by: pkg-fallout Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'comms')
-rw-r--r--comms/usbmuxd/files/patch-ppoll25
1 files changed, 25 insertions, 0 deletions
diff --git a/comms/usbmuxd/files/patch-ppoll b/comms/usbmuxd/files/patch-ppoll
new file mode 100644
index 000000000000..6e72aa8eacf1
--- /dev/null
+++ b/comms/usbmuxd/files/patch-ppoll
@@ -0,0 +1,25 @@
+diff --git configure.ac configure.ac
+index 6c2481a..d204ba0 100644
+--- configure.ac
++++ configure.ac
+@@ -96,6 +96,7 @@ AC_TYPE_UINT8_T
+ AC_FUNC_MALLOC
+ AC_FUNC_REALLOC
+ AC_CHECK_FUNCS([strcasecmp strdup strerror strndup stpcpy])
++AC_CHECK_FUNCS([ppoll])
+
+ # Check for operating system
+ AC_MSG_CHECKING([whether to enable WIN32 build settings])
+diff --git src/main.c src/main.c
+index 2e4439c..cfe6acc 100644
+--- src/main.c
++++ src/main.c
+@@ -159,7 +159,7 @@ static void set_signal_handlers(void)
+ sigaction(SIGUSR2, &sa, NULL);
+ }
+
+-#if defined(__FreeBSD__) || defined(__APPLE__)
++#ifndef HAVE_PPOLL
+ static int ppoll(struct pollfd *fds, nfds_t nfds, const struct timespec *timeout, const sigset_t *sigmask)
+ {
+ int ready;