aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-04 15:05:51 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-04 15:05:51 +0800
commitf82fe9bf353267aff53d27b84fddc579ee10805c (patch)
treecaabb9b9009c41e2a1048fbdfedee6f781bb88bd /comms
parentdbda535fdd2421f51ef2b67bfcb90f8ae2565228 (diff)
downloadfreebsd-ports-gnome-f82fe9bf353267aff53d27b84fddc579ee10805c.tar.gz
freebsd-ports-gnome-f82fe9bf353267aff53d27b84fddc579ee10805c.tar.zst
freebsd-ports-gnome-f82fe9bf353267aff53d27b84fddc579ee10805c.zip
comms/dabstick-radio: unbreak build with ffmpeg 3.x
backend/mp2processor-ffmpeg.cpp:49:33: error: use of undeclared identifier 'CODEC_ID_MP1'; did you mean 'AV_CODEC_ID_MP1'? codec = avcodec_find_decoder (CODEC_ID_MP1); ^~~~~~~~~~~~ In file included from backend/mp2processor.cpp:7: backend/mp2processor-ffmpeg.cpp:66:18: error: use of undeclared identifier 'avcodec_alloc_frame' decoded_frame = avcodec_alloc_frame (); ^ backend/mp2processor-ffmpeg.cpp:107:2: error: use of undeclared identifier 'avcodec_get_frame_defaults' avcodec_get_frame_defaults (decoded_frame); ^ PR: 207547
Diffstat (limited to 'comms')
-rw-r--r--comms/dabstick-radio/Makefile2
-rw-r--r--comms/dabstick-radio/files/patch-dabreceiver-V2_backend_mp2processor-ffmpeg.cpp29
2 files changed, 30 insertions, 1 deletions
diff --git a/comms/dabstick-radio/Makefile b/comms/dabstick-radio/Makefile
index 868e5eaf1773..24279e618f09 100644
--- a/comms/dabstick-radio/Makefile
+++ b/comms/dabstick-radio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dabstick-radio
PORTVERSION= 0.96
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= comms audio hamradio
MASTER_SITES= http://www.sdr-j.tk/ \
LOCAL/nox/
diff --git a/comms/dabstick-radio/files/patch-dabreceiver-V2_backend_mp2processor-ffmpeg.cpp b/comms/dabstick-radio/files/patch-dabreceiver-V2_backend_mp2processor-ffmpeg.cpp
new file mode 100644
index 000000000000..3ababc70545e
--- /dev/null
+++ b/comms/dabstick-radio/files/patch-dabreceiver-V2_backend_mp2processor-ffmpeg.cpp
@@ -0,0 +1,29 @@
+--- dabreceiver-V2/backend/mp2processor-ffmpeg.cpp.orig 2013-05-20 16:11:57 UTC
++++ dabreceiver-V2/backend/mp2processor-ffmpeg.cpp
+@@ -46,7 +46,7 @@ int32_t mp2sampleRate (uint8_t *frame) {
+
+ avcodec_register_all ();
+ av_init_packet (&avpkt);
+- codec = avcodec_find_decoder (CODEC_ID_MP1);
++ codec = avcodec_find_decoder (AV_CODEC_ID_MP1);
+ if (codec == NULL) {
+ fprintf (stderr, "Codec not found\n");
+ return;
+@@ -63,7 +63,7 @@ int32_t mp2sampleRate (uint8_t *frame) {
+ return;
+ }
+
+- decoded_frame = avcodec_alloc_frame ();
++ decoded_frame = av_frame_alloc ();
+ if (decoded_frame == NULL) {
+ fprintf (stderr, "Could not allocate audioframe\n");
+ return;
+@@ -104,7 +104,7 @@ int32_t got_frame;
+ (void)fwrite (MP2frame, sizeof (uint8_t), MP2framebytes, mp2File);
+ return;
+ }
+- avcodec_get_frame_defaults (decoded_frame);
++ av_frame_unref (decoded_frame);
+
+ avpkt. data = MP2frame;
+ avpkt. size = MP2framebytes + 20;