aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2009-08-05 00:18:53 +0800
committerdb <db@FreeBSD.org>2009-08-05 00:18:53 +0800
commit3988212a47d8817d69d6a71fd069355fc562fd4b (patch)
tree58961caa4f3e3064e7a7e9406c126aff3b5fb69b /comms
parent87fdbc5039cceb4cbf69c889e5023bab2fb33b9d (diff)
downloadfreebsd-ports-gnome-3988212a47d8817d69d6a71fd069355fc562fd4b.tar.gz
freebsd-ports-gnome-3988212a47d8817d69d6a71fd069355fc562fd4b.tar.zst
freebsd-ports-gnome-3988212a47d8817d69d6a71fd069355fc562fd4b.zip
- Patch submitted via e-mail by Emanuele Madeo (author of xwota)
- Submitted to Emanuele by Lucian Langa cooly@gnome.eu.org - ... likely strcpy (eor, "<EOR>"); will overflow eor because of terminating null byte. Submitted by: e.madeo@fabaris.it
Diffstat (limited to 'comms')
-rw-r--r--comms/xwota/Makefile2
-rw-r--r--comms/xwota/files/patch-src_stuff.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/comms/xwota/Makefile b/comms/xwota/Makefile
index 2518cfa26b80..0730d4ad2f1a 100644
--- a/comms/xwota/Makefile
+++ b/comms/xwota/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xwota
PORTVERSION= 0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms hamradio
MASTER_SITES= http://people.fabaris.it/iz0ete/xwota/ \
${MASTER_SITE_LOCAL}
diff --git a/comms/xwota/files/patch-src_stuff.c b/comms/xwota/files/patch-src_stuff.c
index 4bbebc7a6979..4ffb37bcd237 100644
--- a/comms/xwota/files/patch-src_stuff.c
+++ b/comms/xwota/files/patch-src_stuff.c
@@ -1,5 +1,5 @@
---- src/stuff.c.orig Wed Sep 13 15:23:19 2006
-+++ src/stuff.c Wed Sep 13 15:24:18 2006
+--- src/stuff.c.orig 2006-07-28 12:00:10.000000000 -0400
++++ src/stuff.c 2009-08-04 12:03:56.000000000 -0400
@@ -22,6 +22,7 @@
#include "global.h"
#include "stuff.h"
@@ -8,3 +8,12 @@
int load_preferences()
+@@ -330,7 +331,7 @@
+ GtkTreePath *path;
+ GtkWidget *spot_list;
+
+-char eor[5];
++char eor[6];
+ char *p_eor;
+ gchar *call,*freq,*country,*state,*grid,*county,*lat,*longitude,*status,*comments,*program,*f1,*f2,*d_ate,*t_ime;
+ char datetime[50],latlong[50],status_comment[30],display_country[50];