aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-06 02:57:59 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-06 02:57:59 +0800
commit4c2985df47d3c20bf647e106db3f3e848d9f294f (patch)
tree634e4fa1c0f9f35867773e175340c230382d26eb /comms
parente5edc4b6b27e7fdec80c6fd5536e71620a3b73da (diff)
downloadfreebsd-ports-gnome-4c2985df47d3c20bf647e106db3f3e848d9f294f.tar.gz
freebsd-ports-gnome-4c2985df47d3c20bf647e106db3f3e848d9f294f.tar.zst
freebsd-ports-gnome-4c2985df47d3c20bf647e106db3f3e848d9f294f.zip
comms/linpsk: unbreak with clang 4.0
crxdisplay.cpp:101:16: error: ordered comparison between pointer and zero ('Input *' and 'int') if ( Sound <= NULL ) ~~~~~ ^ ~~~~ PR: 216234 Submitted by: tcberner Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'comms')
-rw-r--r--comms/linpsk/Makefile1
-rw-r--r--comms/linpsk/files/patch-gui_crxdisplay.cpp13
-rw-r--r--comms/linpsk/files/patch-gui_linpsk.cpp22
3 files changed, 36 insertions, 0 deletions
diff --git a/comms/linpsk/Makefile b/comms/linpsk/Makefile
index 5319d9623ede..09d58e2b9a16 100644
--- a/comms/linpsk/Makefile
+++ b/comms/linpsk/Makefile
@@ -2,6 +2,7 @@
PORTNAME= linpsk
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/comms/linpsk/files/patch-gui_crxdisplay.cpp b/comms/linpsk/files/patch-gui_crxdisplay.cpp
new file mode 100644
index 000000000000..fd5a2666f7cb
--- /dev/null
+++ b/comms/linpsk/files/patch-gui_crxdisplay.cpp
@@ -0,0 +1,13 @@
+Fix bogus pointer comparison.
+
+--- gui/crxdisplay.cpp.orig 2017-01-22 12:03:47 UTC
++++ gui/crxdisplay.cpp
+@@ -98,7 +98,7 @@ bool CRxDisplay::start_process_loop()
+ }
+ else
+ Sound = new CSound ( settings.serial );
+- if ( Sound <= NULL )
++ if ( !Sound )
+ return false;
+
+ connect ( Sound, SIGNAL ( samplesAvailable() ), this, SLOT ( process_rxdata() ) );
diff --git a/comms/linpsk/files/patch-gui_linpsk.cpp b/comms/linpsk/files/patch-gui_linpsk.cpp
new file mode 100644
index 000000000000..6617d43ef596
--- /dev/null
+++ b/comms/linpsk/files/patch-gui_linpsk.cpp
@@ -0,0 +1,22 @@
+Fix bogus pointer comparison.
+
+--- gui/linpsk.cpp.orig 2017-01-22 12:03:55 UTC
++++ gui/linpsk.cpp
+@@ -387,7 +387,7 @@ void LinPSK::startTx()
+ Info = "BPSK";
+ break;
+ }
+- if ( Sound <= NULL ) // Only create Sound Device once for output
++ if ( !Sound ) // Only create Sound Device once for output
+ {
+ if ( settings.DemoMode )
+ {
+@@ -401,7 +401,7 @@ void LinPSK::startTx()
+ Sound = new CSound ( settings.serial );
+ connect ( Sound, SIGNAL ( samplesAvailable() ), this, SLOT ( process_txdata() ) );
+ }
+- if ( Sound <= NULL )
++ if ( !Sound )
+ {
+ QMessageBox::critical ( 0, " Programm Error! LinPsk", "Could not create Sound Device for Output" );
+ TxDisplay->TxFunctions->setStatus ( ON );