aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2011-03-16 04:41:27 +0800
committernox <nox@FreeBSD.org>2011-03-16 04:41:27 +0800
commitfc7f8eb211816de6db66ab16018a9747bbc0d845 (patch)
tree036bf6105ef417e5fd763d02fefcdfca96dec11a /comms
parenta1299ccd60cf1d09522ea708e25699d5390fce15 (diff)
downloadfreebsd-ports-gnome-fc7f8eb211816de6db66ab16018a9747bbc0d845.tar.gz
freebsd-ports-gnome-fc7f8eb211816de6db66ab16018a9747bbc0d845.tar.zst
freebsd-ports-gnome-fc7f8eb211816de6db66ab16018a9747bbc0d845.zip
- Add patch to fix MAKE_JOBS_SAFE and mark as such.
- No PORTREVISION bump as the installed bits don't change.
Diffstat (limited to 'comms')
-rw-r--r--comms/lirc/Makefile1
-rw-r--r--comms/lirc/files/patch-daemons-Makefile.am11
2 files changed, 12 insertions, 0 deletions
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 1d9f360e901e..ed088cae4a0f 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -23,6 +23,7 @@ USE_XORG= x11
USE_PYTHON= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/lirc/files/patch-daemons-Makefile.am b/comms/lirc/files/patch-daemons-Makefile.am
new file mode 100644
index 000000000000..f641b87739cb
--- /dev/null
+++ b/comms/lirc/files/patch-daemons-Makefile.am
@@ -0,0 +1,11 @@
+--- daemons/Makefile.am.orig
++++ daemons/Makefile.am
+@@ -83,7 +83,7 @@ irrecord_SOURCES = irrecord.c \
+ transmit.c transmit.h
+
+ irrecord_LDADD = libhw_module.a @hw_module_libs@ @receive@
+-irrecord_DEPENDENCIES = @receive@
++irrecord_DEPENDENCIES = libhw_module.a @receive@
+
+ ## maintainer mode stuff
+ EXTRA_PROGRAMS = lircd.simsend lircd.simrec slinke