aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2004-01-13 23:07:29 +0800
committerjmz <jmz@FreeBSD.org>2004-01-13 23:07:29 +0800
commit34154b71373bb2171634249921f2215a39a59427 (patch)
tree9727715c3f19411838ddaeb489ffe52cd8baf474 /comms
parentf2dfb46ae8ac1738ec770197851de2707b334c3d (diff)
downloadfreebsd-ports-gnome-34154b71373bb2171634249921f2215a39a59427.tar.gz
freebsd-ports-gnome-34154b71373bb2171634249921f2215a39a59427.tar.zst
freebsd-ports-gnome-34154b71373bb2171634249921f2215a39a59427.zip
Fix a buffer overflow problem.
Submitted by: guy@device.dyndns.org
Diffstat (limited to 'comms')
-rw-r--r--comms/viewfax/Makefile1
-rw-r--r--comms/viewfax/files/patch-aa2
2 files changed, 2 insertions, 1 deletions
diff --git a/comms/viewfax/Makefile b/comms/viewfax/Makefile
index e84d4067e343..016158a112a4 100644
--- a/comms/viewfax/Makefile
+++ b/comms/viewfax/Makefile
@@ -7,6 +7,7 @@
PORTNAME= viewfax
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= ftp://ftp.leo.org/pub/comp/os/unix/networking/mgetty/
diff --git a/comms/viewfax/files/patch-aa b/comms/viewfax/files/patch-aa
index 844595ffa52d..b8782ecf2042 100644
--- a/comms/viewfax/files/patch-aa
+++ b/comms/viewfax/files/patch-aa
@@ -5,7 +5,7 @@
n = *r++;
tot += n;
+ /* Watch out for buffer overruns, e.g. when n == 65535. */
-+ if (tot > pn->width)
++ if (tot >= pn->width)
+ break;
if (pix)
acc |= (~(t32bits)0 >> nacc);