aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-11-27 15:40:51 +0800
committersem <sem@FreeBSD.org>2005-11-27 15:40:51 +0800
commit5644ff87701ad71b9820328afbbf194fa3f9d0bc (patch)
tree50d44e8c6792864bf95096e231040b8200049c9c /comms
parent280ea2061a1c7326a671fa3ce3bc38dbc7ccc90c (diff)
downloadfreebsd-ports-gnome-5644ff87701ad71b9820328afbbf194fa3f9d0bc.tar.gz
freebsd-ports-gnome-5644ff87701ad71b9820328afbbf194fa3f9d0bc.tar.zst
freebsd-ports-gnome-5644ff87701ad71b9820328afbbf194fa3f9d0bc.zip
- Fix serial ports name for FreeBSD >= 6.0
PR: ports/89282 Reported by: Karsten Thygesen
Diffstat (limited to 'comms')
-rw-r--r--comms/ruby-serialport/Makefile1
-rw-r--r--comms/ruby-serialport/files/patch-serialport.c27
2 files changed, 28 insertions, 0 deletions
diff --git a/comms/ruby-serialport/Makefile b/comms/ruby-serialport/Makefile
index a6f9b6f0edf0..55f22b35c7fa 100644
--- a/comms/ruby-serialport/Makefile
+++ b/comms/ruby-serialport/Makefile
@@ -7,6 +7,7 @@
PORTNAME= serialport
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= comms ruby
MASTER_SITES= http://rubyforge.org/frs/download.php/72/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
diff --git a/comms/ruby-serialport/files/patch-serialport.c b/comms/ruby-serialport/files/patch-serialport.c
new file mode 100644
index 000000000000..1830a5874f34
--- /dev/null
+++ b/comms/ruby-serialport/files/patch-serialport.c
@@ -0,0 +1,27 @@
+--- serialport.c.orig Sun Nov 27 10:28:52 2005
++++ serialport.c Sun Nov 27 10:35:17 2005
+@@ -20,6 +20,10 @@
+ #include <ruby.h> /* ruby inclusion */
+ #include <rubyio.h> /* ruby io inclusion */
+
++#if defined (freebsd)
++#include <sys/param.h>
++#endif
++
+ struct modem_params {
+ int data_rate;
+ int data_bits;
+@@ -569,9 +573,12 @@
+ #if defined(linux) || defined(cygwin)
+ "/dev/ttyS0", "/dev/ttyS1", "/dev/ttyS2", "/dev/ttyS3",
+ "/dev/ttyS4", "/dev/ttyS5", "/dev/ttyS6", "/dev/ttyS7"
+-#elif defined(freebsd) || defined(netbsd) || defined(openbsd)
++#elif (defined(freebsd) && __FreeBSD_version < 600006) || defined(netbsd) || defined(openbsd)
+ "/dev/cuaa0", "/dev/cuaa1", "/dev/cuaa2", "/dev/cuaa3",
+ "/dev/cuaa4", "/dev/cuaa5", "/dev/cuaa6", "/dev/cuaa7"
++#elif (defined(freebsd) && __FreeBSD_version >= 600006)
++ "/dev/cuad0", "/dev/cuad1", "/dev/cuad2", "/dev/cuad3",
++ "/dev/cuad4", "/dev/cuad5", "/dev/cuad6", "/dev/cuad7"
+ #elif defined(solaris)
+ "/dev/ttya", "/dev/ttyb", "/dev/ttyc", "/dev/ttyd",
+ "/dev/ttye", "/dev/ttyf", "/dev/ttyg", "/dev/ttyh"