aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
committermat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
commit79c3ac81e82fba101ce34956c5de634b8ed032d0 (patch)
treeaa20f69168c1d6c9e0dbf200cc417eb6ea9147ca /comms
parent89ac30bfd79e5d0fe14f37fae8ce263170a2af2d (diff)
downloadfreebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.gz
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.zst
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.zip
Remove all := from BUILD_DEPENDS, here are never needed.
While there, cleanup, and sort depends. When build and run dependencies are the same, there are three ways to avoid duplicating the list while not adding the framework added BUILD_DEPENDS to the RUN_DEPENDS. In order of preference, they are: 1) use RUN_DEPENDS to set BUILD_DEPENDS: BUILD_DEPENDS= ${RUN_DEPENDS} RUN_DEPENDS= foo:bar/baz 2) create another variable and use it: MY_DEPENDS= foo:bar/baz BUILD_DEPENDS= ${MY_DEPENDS} RUN_DEPENDS= ${MY_DEPENDS} 3) use BUILD_DEPENDS to set RUN_DEPENDS and force evaluation: BUILD_DEPENDS= foo:bar/baz RUN_DEPENDS:= ${BUILD_DEPENDS} Sponsored by: Absolight
Diffstat (limited to 'comms')
-rw-r--r--comms/p5-SMS-Send-TW-PChome/Makefile2
-rw-r--r--comms/p5-SMS-Send-TW-Qma/Makefile2
-rw-r--r--comms/p5-SMS-Send-TW-Socket2Air/Makefile2
-rw-r--r--comms/p5-SMS-Send-TW-chtsns/Makefile2
-rw-r--r--comms/p5-SMS-Send-TW-emome/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/comms/p5-SMS-Send-TW-PChome/Makefile b/comms/p5-SMS-Send-TW-PChome/Makefile
index f678beb2de12..756ca74c457d 100644
--- a/comms/p5-SMS-Send-TW-PChome/Makefile
+++ b/comms/p5-SMS-Send-TW-PChome/Makefile
@@ -11,11 +11,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= SMS::Send driver for sms.pchome.com.tw
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-SMS-Send>=0:comms/p5-SMS-Send \
p5-Text-Iconv>=0:converters/p5-Text-Iconv \
p5-WWW-Mechanize>=0:www/p5-WWW-Mechanize \
p5-Crypt-SSLeay>=0:security/p5-Crypt-SSLeay
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send-TW-Qma/Makefile b/comms/p5-SMS-Send-TW-Qma/Makefile
index 14a48d28a0ac..0bef82ba044b 100644
--- a/comms/p5-SMS-Send-TW-Qma/Makefile
+++ b/comms/p5-SMS-Send-TW-Qma/Makefile
@@ -11,10 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= SMS::Send driver for http://www.qma.com/
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-SMS-Send>=0:comms/p5-SMS-Send \
p5-Crypt-SSLeay>=0.57:security/p5-Crypt-SSLeay \
p5-WWW-Mechanize>=0:www/p5-WWW-Mechanize
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send-TW-Socket2Air/Makefile b/comms/p5-SMS-Send-TW-Socket2Air/Makefile
index 199b2e078135..f7ebde8e031d 100644
--- a/comms/p5-SMS-Send-TW-Socket2Air/Makefile
+++ b/comms/p5-SMS-Send-TW-Socket2Air/Makefile
@@ -11,11 +11,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jnlin@freebsd.cs.nctu.edu.tw
COMMENT= SMS::Send driver for Socket2Air
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-SMS-Send>=0:comms/p5-SMS-Send \
p5-Switch>=0:lang/p5-Switch \
p5-libwww>=0:www/p5-libwww \
p5-Text-Iconv>=0:converters/p5-Text-Iconv
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send-TW-chtsns/Makefile b/comms/p5-SMS-Send-TW-chtsns/Makefile
index 22f845fe39f6..30298bfd3264 100644
--- a/comms/p5-SMS-Send-TW-chtsns/Makefile
+++ b/comms/p5-SMS-Send-TW-chtsns/Makefile
@@ -11,12 +11,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jnlin@freebsd.cs.nctu.edu.tw
COMMENT= SMS::Send driver for SNS service of CHT
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-SMS-Send>=0:comms/p5-SMS-Send \
p5-Switch>=0:lang/p5-Switch \
p5-libwww>=0:www/p5-libwww \
p5-WWW-Mechanize>=0:www/p5-WWW-Mechanize \
p5-Text-Iconv>=0:converters/p5-Text-Iconv
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send-TW-emome/Makefile b/comms/p5-SMS-Send-TW-emome/Makefile
index 910f71c2e217..23ca885505aa 100644
--- a/comms/p5-SMS-Send-TW-emome/Makefile
+++ b/comms/p5-SMS-Send-TW-emome/Makefile
@@ -11,11 +11,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= SMS::Send driver for www.emome.net
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-SMS-Send>=0.03:comms/p5-SMS-Send \
p5-Crypt-SSLeay>=0.57:security/p5-Crypt-SSLeay \
p5-WWW-Mechanize>=1.20:www/p5-WWW-Mechanize \
p5-Text-Iconv>=:converters/p5-Text-Iconv
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure