aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-05-21 01:29:24 +0800
committertcberner <tcberner@FreeBSD.org>2017-05-21 01:29:24 +0800
commit494fc88782312b563b696f3bbd0221ba24a696cd (patch)
tree58226b3fae7e905e7624d6165889ea3441786e71 /comms
parent7e19a4546a7728714a58041e8e423c5f9448c59b (diff)
downloadfreebsd-ports-gnome-494fc88782312b563b696f3bbd0221ba24a696cd.tar.gz
freebsd-ports-gnome-494fc88782312b563b696f3bbd0221ba24a696cd.tar.zst
freebsd-ports-gnome-494fc88782312b563b696f3bbd0221ba24a696cd.zip
Fix shebangs.
* Make dependency on pyhthon explicit. Approved by: rakuco (mentor, implicit)
Diffstat (limited to 'comms')
-rw-r--r--comms/usrp/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/comms/usrp/Makefile b/comms/usrp/Makefile
index e1262f390522..c82ef1eb09bf 100644
--- a/comms/usrp/Makefile
+++ b/comms/usrp/Makefile
@@ -2,7 +2,7 @@
PORTNAME= usrp
PORTVERSION= 3.4.3
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= comms hamradio
MASTER_SITES= LOCAL/adrian
DISTNAME= Ettus-USRP-3.4.3
@@ -17,12 +17,15 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs \
orcc:devel/orc \
sdcc:lang/sdcc
-USES= compiler:c++0x cmake:outsource gmake pkgconfig dos2unix
+USES= compiler:c++0x cmake:outsource gmake pkgconfig python:run \
+ dos2unix shebangfix
COMPILER_FEATURES= libc++
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
MAKE_JOBS_UNSAFE= yes
+SHEBANG_GLOB= *.py
+
# for excruciating debug use this -db
#CMAKE_ARGS+= --debug-output --trace
DOCSDIR= share/doc/uhd