aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-03 16:18:56 +0800
committermiwi <miwi@FreeBSD.org>2014-06-03 16:18:56 +0800
commit7358a6ded079b871888a2edf6e6f4338814a1d28 (patch)
treea44e766da75ef641a35ba7f1b03b7473d7bd0eaa /comms
parentdbda4f203b952faf825a575704d48a836f700b31 (diff)
downloadfreebsd-ports-gnome-7358a6ded079b871888a2edf6e6f4338814a1d28.tar.gz
freebsd-ports-gnome-7358a6ded079b871888a2edf6e6f4338814a1d28.tar.zst
freebsd-ports-gnome-7358a6ded079b871888a2edf6e6f4338814a1d28.zip
The concordance software suite allows you to program your Logitech Harmony
remote using a configuration object retreived from the harmony website. The Logitech Harmony is a highly configuration universal remote than can control most multimedia devices. This port contains the Python bindings for the concordance framework. PR: ports/190547 Submitted by: Stephen Hurd <shurd@sasktel.net>
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/py-libconcord/Makefile24
-rw-r--r--comms/py-libconcord/distinfo2
-rw-r--r--comms/py-libconcord/pkg-descr6
-rw-r--r--comms/py-libconcord/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 473b27437352..3aadcea9375a 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -120,6 +120,7 @@
SUBDIR += pr
SUBDIR += predict
SUBDIR += py-bulksms
+ SUBDIR += py-libconcord
SUBDIR += py-libimobiledevice
SUBDIR += py-lirc
SUBDIR += py-serial
diff --git a/comms/py-libconcord/Makefile b/comms/py-libconcord/Makefile
new file mode 100644
index 000000000000..e496e51c3365
--- /dev/null
+++ b/comms/py-libconcord/Makefile
@@ -0,0 +1,24 @@
+# Created by: Stephen Hurd <shurd@sasktel.net>
+# $FreeBSD$
+
+PORTNAME= libconcord
+PORTVERSION= 1.1
+CATEGORIES= comms
+MASTER_SITES= SF/concordance/concordance/${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= concordance-${PORTVERSION}
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Python bindings for Logitech Harmony library
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libconcord.so:${PORTSDIR}/comms/libconcord
+
+USE_LDCONFIG= yes
+USES= tar:bzip2
+WRKSRC_SUBDIR= libconcord/bindings/python
+USE_PYTHON= 2.7+
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/comms/py-libconcord/distinfo b/comms/py-libconcord/distinfo
new file mode 100644
index 000000000000..e380d1ba87ed
--- /dev/null
+++ b/comms/py-libconcord/distinfo
@@ -0,0 +1,2 @@
+SHA256 (concordance-1.1.tar.bz2) = ca5ffbd8c0fd06d41192c1d5e3c8b964c2393ea6d3d9c5e495c1da4b2c778a05
+SIZE (concordance-1.1.tar.bz2) = 1142393
diff --git a/comms/py-libconcord/pkg-descr b/comms/py-libconcord/pkg-descr
new file mode 100644
index 000000000000..bcd059aced5b
--- /dev/null
+++ b/comms/py-libconcord/pkg-descr
@@ -0,0 +1,6 @@
+The concordance software suite allows you to program your Logitech Harmony
+remote using a configuration object retreived from the harmony website. The
+Logitech Harmony is a highly configuration universal remote than can control
+most multimedia devices.
+
+This port contains the Python bindings for the concordance framework.
diff --git a/comms/py-libconcord/pkg-plist b/comms/py-libconcord/pkg-plist
new file mode 100644
index 000000000000..b9de8672efc4
--- /dev/null
+++ b/comms/py-libconcord/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/libconcord.py
+%%PYTHON_SITELIBDIR%%/libconcord.pyc
+%%PYTHON_SITELIBDIR%%/libconcord.pyo