aboutsummaryrefslogtreecommitdiffstats
path: root/converters/bibtexconv/Makefile
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-11-09 21:34:00 +0800
committerwg <wg@FreeBSD.org>2013-11-09 21:34:00 +0800
commit3d62e3ecf7955c251dec2500d4e6d1b810b0ea39 (patch)
tree4101202d01868e7d622cf22aef217b1432a810ee /converters/bibtexconv/Makefile
parent5cf5c5ef1e6e47ef1e577c3716dd3baebeca6736 (diff)
downloadfreebsd-ports-gnome-3d62e3ecf7955c251dec2500d4e6d1b810b0ea39.tar.gz
freebsd-ports-gnome-3d62e3ecf7955c251dec2500d4e6d1b810b0ea39.tar.zst
freebsd-ports-gnome-3d62e3ecf7955c251dec2500d4e6d1b810b0ea39.zip
converters/bibtexconv: update to 1.0.0
- Update to 1.0.0 - Allow staging PR: ports/183610 (based on) Submitted by: maintainer
Diffstat (limited to 'converters/bibtexconv/Makefile')
-rw-r--r--converters/bibtexconv/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/converters/bibtexconv/Makefile b/converters/bibtexconv/Makefile
index f79701f48c93..8c0e91f16b84 100644
--- a/converters/bibtexconv/Makefile
+++ b/converters/bibtexconv/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bibtexconv
-PORTVERSION= 0.9.3
-PORTREVISION= 1
+PORTVERSION= 1.0.0
CATEGORIES= converters
MASTER_SITES= http://www.iem.uni-due.de/~dreibh/bibtexconv/download/ \
http://www.exp-math.uni-essen.de/~dreibh/bibtexconv/download/
@@ -13,27 +12,25 @@ COMMENT= BibTeX Converter
LICENSE= GPLv3
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
-PLIST_FILES= bin/bibtexconv bin/bibtexconv-odt
-PORTEXAMPLES= ExampleReferences.bib ODT-Template.odt odt-example.export \
- web-example.export text-example.export
-MAN1= bibtexconv.1 bibtexconv-odt.1
+PLIST_FILES= bin/bibtexconv bin/bibtexconv-odt \
+ man/man1/bibtexconv.1.gz man/man1/bibtexconv-odt.1.gz
+
+PORTEXAMPLES= ExampleReferences.bib ODT-Template.odt odt-example.export \
+ web-example.export text-example.export
+
+OPTIONS_DEFINE= EXAMPLES
-NO_STAGE= yes
pre-configure:
@${REINPLACE_CMD} -e 's|install-data-am: install-dist_examplesDATA|install-data-am:|' \
${WRKSRC}/src/Makefile.in
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
-.for f in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/src/${f} ${EXAMPLESDIR}
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/src/,} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>