aboutsummaryrefslogtreecommitdiffstats
path: root/converters/enca
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2002-10-24 01:04:23 +0800
committerobraun <obraun@FreeBSD.org>2002-10-24 01:04:23 +0800
commitce0b36a4a6c5c19a4d2067d963ad1826341f708e (patch)
treef417ae39d4de52b608939291a9bda5887897e3a5 /converters/enca
parenta762179786b75d3c13f7c6bd06f2a7bca2047275 (diff)
downloadfreebsd-ports-gnome-ce0b36a4a6c5c19a4d2067d963ad1826341f708e.tar.gz
freebsd-ports-gnome-ce0b36a4a6c5c19a4d2067d963ad1826341f708e.tar.zst
freebsd-ports-gnome-ce0b36a4a6c5c19a4d2067d963ad1826341f708e.zip
Add support for NOPORTDOCS.
PR: 44412 Submitted by: maintainer
Diffstat (limited to 'converters/enca')
-rw-r--r--converters/enca/Makefile6
-rw-r--r--converters/enca/pkg-plist18
2 files changed, 15 insertions, 9 deletions
diff --git a/converters/enca/Makefile b/converters/enca/Makefile
index 7021af5e0268..b69a049ddf45 100644
--- a/converters/enca/Makefile
+++ b/converters/enca/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_BZIP2= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc/enca \
--without-librecode \
@@ -27,4 +28,9 @@ CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
MAN1= enca.1
MLINKS= enca.1 enconv.1
+post-patch::
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's#\ devel-docs##g' ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>
diff --git a/converters/enca/pkg-plist b/converters/enca/pkg-plist
index 49cbc7547956..18a0c705f8c3 100644
--- a/converters/enca/pkg-plist
+++ b/converters/enca/pkg-plist
@@ -8,12 +8,12 @@ include/enca.h
lib/libenca.a
lib/libenca.so
lib/libenca.so.2
-share/doc/enca/libenca/c4.html
-share/doc/enca/libenca/index.html
-share/doc/enca/libenca/index.sgml
-share/doc/enca/libenca/libenca-analyser.html
-share/doc/enca/libenca/libenca-auxiliary-functions.html
-share/doc/enca/libenca/libenca-charsets-and-surfaces.html
-share/doc/enca/libenca/libenca-typedefs-and-constants.html
-@dirrm share/doc/enca/libenca
-@dirrm share/doc/enca
+%%PORTDOCS%%share/doc/enca/libenca/c4.html
+%%PORTDOCS%%share/doc/enca/libenca/index.html
+%%PORTDOCS%%share/doc/enca/libenca/index.sgml
+%%PORTDOCS%%share/doc/enca/libenca/libenca-analyser.html
+%%PORTDOCS%%share/doc/enca/libenca/libenca-auxiliary-functions.html
+%%PORTDOCS%%share/doc/enca/libenca/libenca-charsets-and-surfaces.html
+%%PORTDOCS%%share/doc/enca/libenca/libenca-typedefs-and-constants.html
+%%PORTDOCS%%@dirrm share/doc/enca/libenca
+%%PORTDOCS%%@dirrm share/doc/enca