aboutsummaryrefslogtreecommitdiffstats
path: root/converters/fix-mime-charset
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-01-08 10:50:16 +0800
committeredwin <edwin@FreeBSD.org>2004-01-08 10:50:16 +0800
commit15a9585281691288decf2cda5fdab4e9b8124271 (patch)
treeeade373ff1b5f150cfa8bca34ff2c865edebfb27 /converters/fix-mime-charset
parent9ad375565120fcfa74b858ad52491b362431c38a (diff)
downloadfreebsd-ports-gnome-15a9585281691288decf2cda5fdab4e9b8124271.tar.gz
freebsd-ports-gnome-15a9585281691288decf2cda5fdab4e9b8124271.tar.zst
freebsd-ports-gnome-15a9585281691288decf2cda5fdab4e9b8124271.zip
New port: converters/fix-mime-charset - Fix incorrect Content-Type
MIME headers of e-mail messages Categories: converters textproc russian ukrainian Fix-mime-charset automatically detects character sets of email message and modifies the Content-Type header appropriately. It can be used as mail filter in mailing lists where users often set the charset of their messages incorrectly. It processes messages fast and accurately, ignoring attachments, and correctly interprets transfer-encodings. None but the Content-Type header is changed. PR: ports/61050 Submitted by: Nosov Artem <chip-set@mail.ru>
Diffstat (limited to 'converters/fix-mime-charset')
-rw-r--r--converters/fix-mime-charset/Makefile39
-rw-r--r--converters/fix-mime-charset/distinfo1
-rw-r--r--converters/fix-mime-charset/pkg-descr9
-rw-r--r--converters/fix-mime-charset/pkg-plist1
4 files changed, 50 insertions, 0 deletions
diff --git a/converters/fix-mime-charset/Makefile b/converters/fix-mime-charset/Makefile
new file mode 100644
index 000000000000..5a494aa06442
--- /dev/null
+++ b/converters/fix-mime-charset/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: fix-mime-charset
+# Date created: 26 November 2003
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fix-mime-charset
+PORTVERSION= 0.5.2
+CATEGORIES= converters textproc russian ukrainian
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fix-mime-chr
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= Fix incorrect Content-Type MIME headers of e-mail messages
+
+LIB_DEPENDS= enca.3:${PORTSDIR}/converters/enca
+
+PORTDOCS= README.koi8r README
+
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+USE_PERL5_BUILD= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= fix-mime-charset.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/converters/fix-mime-charset/distinfo b/converters/fix-mime-charset/distinfo
new file mode 100644
index 000000000000..b4c2d0740277
--- /dev/null
+++ b/converters/fix-mime-charset/distinfo
@@ -0,0 +1 @@
+MD5 (fix-mime-charset-0.5.2.tar.gz) = 4380dadef00657817dd61a35e51a1d17
diff --git a/converters/fix-mime-charset/pkg-descr b/converters/fix-mime-charset/pkg-descr
new file mode 100644
index 000000000000..f43328a201db
--- /dev/null
+++ b/converters/fix-mime-charset/pkg-descr
@@ -0,0 +1,9 @@
+Fix-mime-charset automatically detects character sets of email message and
+modifies the Content-Type header appropriately. It can be used as mail
+filter in mailing lists where users often set the charset of their messages
+incorrectly. It processes messages fast and accurately, ignoring
+attachments, and correctly interprets transfer-encodings. None but the
+Content-Type header is changed.
+
+- Nosov Artem
+chip-set@mail.ru
diff --git a/converters/fix-mime-charset/pkg-plist b/converters/fix-mime-charset/pkg-plist
new file mode 100644
index 000000000000..24704554ff84
--- /dev/null
+++ b/converters/fix-mime-charset/pkg-plist
@@ -0,0 +1 @@
+bin/fix-mime-charset