aboutsummaryrefslogtreecommitdiffstats
path: root/converters/libb64
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-03 18:43:55 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-03 18:43:55 +0800
commitf9f1d7f23f4b440cd2a84e46108980402d1ea32d (patch)
tree8eeaf1f73b5d8e67a757eed72fb68ac3634a63c0 /converters/libb64
parentef9de7a60937563bf696f34a64c836affbd9a258 (diff)
downloadfreebsd-ports-gnome-f9f1d7f23f4b440cd2a84e46108980402d1ea32d.tar.gz
freebsd-ports-gnome-f9f1d7f23f4b440cd2a84e46108980402d1ea32d.tar.zst
freebsd-ports-gnome-f9f1d7f23f4b440cd2a84e46108980402d1ea32d.zip
- Improve COMMENT: make it concise and mention that it's about Base64
- Unbreak the build on PowerPC by adding -fsigned-char to CFLAGS (and also respect them by removing hardcoded -O3) - Rename a patch and regenerate it with `make makepatch' command - Clean up do-install target (sanitize symlink, wrap overly long line) - Reformat and kill EOL whitespace in the port description text
Diffstat (limited to 'converters/libb64')
-rw-r--r--converters/libb64/Makefile9
-rw-r--r--converters/libb64/files/patch-src_Makefile (renamed from converters/libb64/files/patch-shared-lib)19
-rw-r--r--converters/libb64/pkg-descr15
3 files changed, 28 insertions, 15 deletions
diff --git a/converters/libb64/Makefile b/converters/libb64/Makefile
index 7281c9205398..41bc5179f01a 100644
--- a/converters/libb64/Makefile
+++ b/converters/libb64/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= converters mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}
MAINTAINER= ismail.yenigul@surgate.com
-COMMENT= Library of ANSI C routines for fast encoding/decoding data
+COMMENT= Library for fast Base64 encoding and decoding
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
@@ -15,13 +15,12 @@ USES= gmake zip
ALL_TARGET= all_src
USE_LDCONFIG= yes
-BROKEN_powerpc= Does not compile on powerpc
-
do-install:
${INSTALL_DATA} ${WRKSRC}/src/libb64.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_LIB} ${WRKSRC}/src/libb64.so.0 ${STAGEDIR}${PREFIX}/lib
- (cd ${STAGEDIR}${PREFIX}/lib && ${LN} -fs libb64.so.0 libb64.so)
+ ${LN} -fs libb64.so.0 ${STAGEDIR}${PREFIX}/lib/libb64.so
@${MKDIR} ${STAGEDIR}${PREFIX}/include/b64
- ${INSTALL_DATA} ${WRKSRC}/include/b64/*.h ${STAGEDIR}${PREFIX}/include/b64
+ ${INSTALL_DATA} ${WRKSRC}/include/b64/*.h \
+ ${STAGEDIR}${PREFIX}/include/b64
.include <bsd.port.mk>
diff --git a/converters/libb64/files/patch-shared-lib b/converters/libb64/files/patch-src_Makefile
index 0cd2bf234f87..4d6e71375ef8 100644
--- a/converters/libb64/files/patch-shared-lib
+++ b/converters/libb64/files/patch-src_Makefile
@@ -1,12 +1,27 @@
---- src/Makefile~
+--- src/Makefile.orig 2013-06-18 12:49:36 UTC
+++ src/Makefile
-@@ -1,4 +1,5 @@
+@@ -1,9 +1,10 @@
-LIBRARIES = libb64.a
+LIBRARIES = libb64.a libb64.so
+SOVERSION ?= 0
# Build flags (uncomment one)
#############################
+ # Release build flags
+-CFLAGS += -O3
++#CFLAGS += -O3
+ #############################
+ # Debug build flags
+ #CFLAGS += -g
+@@ -15,7 +16,7 @@ TARGETS = $(LIBRARIES)
+
+ LINK.o = gcc
+
+-CFLAGS += -Werror -pedantic
++CFLAGS += -Werror -pedantic -fsigned-char
+ CFLAGS += -I../include
+
+ vpath %.h ../include/b64
@@ -27,6 +28,15 @@ all: $(TARGETS) #strip
libb64.a: cencode.o cdecode.o
$(AR) $(ARFLAGS) $@ $^
diff --git a/converters/libb64/pkg-descr b/converters/libb64/pkg-descr
index ab8810448daa..35b1b03b2f58 100644
--- a/converters/libb64/pkg-descr
+++ b/converters/libb64/pkg-descr
@@ -1,10 +1,9 @@
-libb64 is a library of ANSI C routines for fast encoding/decoding data
-into and from a base64-encoded format.
-C++ wrappers are included, as well as the source code for
-standalone encoding and decoding executables.
+libb64 is a library of ANSI C routines for fast encoding/decoding of data
+into and from a Base64-encoded format. C++ wrappers are included, as well
+as the source code for standalone encoding and decoding executables.
-Base64 uses a subset of displayable ASCII characters, and is
-therefore a useful encoding for storing binary data in a text file,
-such as XML, or sending binary data over text-only email.
+Base64 uses a subset of displayable ASCII characters, and is therefore a
+useful encoding for storing binary data in a text file, such as XML, or
+sending binary data over text-only communication channels.
-WWW: http://libb64.sourceforge.net
+WWW: http://libb64.sourceforge.net/