aboutsummaryrefslogtreecommitdiffstats
path: root/converters/libiconv/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-04-30 02:41:51 +0800
committermarcus <marcus@FreeBSD.org>2002-04-30 02:41:51 +0800
commit5fbe418b9ea7481c031f3d8f146b5f1f550537ce (patch)
tree7f2c2641271c15c240a055a47942363ccc3561c1 /converters/libiconv/Makefile
parent0070b55b94bc9275fcfe0f076ef9627329c33849 (diff)
downloadfreebsd-ports-gnome-5fbe418b9ea7481c031f3d8f146b5f1f550537ce.tar.gz
freebsd-ports-gnome-5fbe418b9ea7481c031f3d8f146b5f1f550537ce.tar.zst
freebsd-ports-gnome-5fbe418b9ea7481c031f3d8f146b5f1f550537ce.zip
Fix a few problems in libiconv.
* Allow libcharset to find charset.alias in the correct place * Add support for the new FreeBSD locales * Fix potential infinite loop when conversion fails * Bump PORTREVISION PR: 37543, 37497 Submitted by: Fuyuhiko Maruyama <fuyuhik8@is.titech.ac.jp> (infinite loop fix) marcus (everything else) Reviewed by: nork (infinite loop fix), sobomax Approved by: sobomax
Diffstat (limited to 'converters/libiconv/Makefile')
-rw-r--r--converters/libiconv/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 1ca53359cf2d..6e0b785bd822 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libiconv
PORTVERSION= 1.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= converters devel
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.ilog.fr/pub/Users/haible/gnu/
@@ -22,4 +22,7 @@ INSTALLS_SHLIB= yes
MAN1= iconv.1
MAN3= iconv.3 iconv_open.3 iconv_close.3
+pre-build:
+ @cd ${WRKSRC} ; /usr/bin/gperf -t -L ANSI-C -H aliases_hash -N aliases_lookup -7 -C -k '1,3-11,$$' -i 1 lib/aliases.gperf > lib/aliases.h
+
.include <bsd.port.mk>