aboutsummaryrefslogtreecommitdiffstats
path: root/converters/libiconv/files
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-06-17 03:11:11 +0800
committermarcus <marcus@FreeBSD.org>2002-06-17 03:11:11 +0800
commitb9d2674c2d6f78f6cc1b89a9355c09ae4a9e16b1 (patch)
tree3f32c4fa3230aead0016b24e68711b514616b9e1 /converters/libiconv/files
parent275673ba5e814377b8f5315752d7d2af44cbbf7c (diff)
downloadfreebsd-ports-gnome-b9d2674c2d6f78f6cc1b89a9355c09ae4a9e16b1.tar.gz
freebsd-ports-gnome-b9d2674c2d6f78f6cc1b89a9355c09ae4a9e16b1.tar.zst
freebsd-ports-gnome-b9d2674c2d6f78f6cc1b89a9355c09ae4a9e16b1.zip
Update to 1.8, and retain shared lib version of 3.
Reviewed by: sobomax
Diffstat (limited to 'converters/libiconv/files')
-rw-r--r--converters/libiconv/files/patch-ad9
-rw-r--r--converters/libiconv/files/patch-include::iconv.h.in13
-rw-r--r--converters/libiconv/files/patch-lib_loop-unicode.h8
-rw-r--r--converters/libiconv/files/patch-src_Makefile.in11
4 files changed, 25 insertions, 16 deletions
diff --git a/converters/libiconv/files/patch-ad b/converters/libiconv/files/patch-ad
index e1d8a76d5079..27f36729367a 100644
--- a/converters/libiconv/files/patch-ad
+++ b/converters/libiconv/files/patch-ad
@@ -1,13 +1,10 @@
-
-$FreeBSD$
-
---- lib/Makefile.in.orig Thu Jun 28 01:37:49 2001
-+++ lib/Makefile.in Sun Mar 17 11:34:57 2002
+--- lib/Makefile.in.orig Sat Jun 15 14:42:20 2002
++++ lib/Makefile.in Sat Jun 15 14:42:27 2002
@@ -39,7 +39,7 @@
# Before making a release, change this according to the libtool documentation,
# section "Library interface versions".
--LIBICONV_VERSION_INFO = 2:4:0
+-LIBICONV_VERSION_INFO = 3:0:1
+LIBICONV_VERSION_INFO = 3
# Needed by $(LIBTOOL).
diff --git a/converters/libiconv/files/patch-include::iconv.h.in b/converters/libiconv/files/patch-include::iconv.h.in
index 625de57a1494..44f5177078e7 100644
--- a/converters/libiconv/files/patch-include::iconv.h.in
+++ b/converters/libiconv/files/patch-include::iconv.h.in
@@ -1,9 +1,9 @@
$FreeBSD$
---- include/iconv.h.in.orig Mon Jun 25 15:06:22 2001
-+++ include/iconv.h.in Sun Mar 17 15:41:14 2002
-@@ -21,6 +21,10 @@
+--- include/iconv.h.in.orig Thu May 23 07:48:42 2002
++++ include/iconv.h.in Sat Jun 15 14:04:11 2002
+@@ -21,6 +21,11 @@
#ifndef _LIBICONV_H
#define _LIBICONV_H
@@ -11,10 +11,11 @@ $FreeBSD$
+#define LIBICONV_PLUG
+#endif
+
- #define _LIBICONV_VERSION 0x0107 /* version number: (major<<8) + minor */
++
+ #define _LIBICONV_VERSION 0x0108 /* version number: (major<<8) + minor */
extern int _libiconv_version; /* Likewise */
-@@ -68,6 +72,8 @@
+@@ -68,6 +73,8 @@
encoding `tocode'. */
#ifndef LIBICONV_PLUG
#define iconv_open libiconv_open
@@ -23,7 +24,7 @@ $FreeBSD$
#endif
extern iconv_t iconv_open (const char* tocode, const char* fromcode);
-@@ -78,17 +84,21 @@
+@@ -78,17 +85,21 @@
Decrements `*outbytesleft' and increments `*outbuf' by the same amount. */
#ifndef LIBICONV_PLUG
#define iconv libiconv
diff --git a/converters/libiconv/files/patch-lib_loop-unicode.h b/converters/libiconv/files/patch-lib_loop-unicode.h
index 29b10554ddba..f06f9765ab52 100644
--- a/converters/libiconv/files/patch-lib_loop-unicode.h
+++ b/converters/libiconv/files/patch-lib_loop-unicode.h
@@ -1,5 +1,5 @@
---- lib/loop_unicode.h.orig Fri Jun 8 22:04:33 2001
-+++ lib/loop_unicode.h Mon Apr 29 05:12:08 2002
+--- lib/loop_unicode.h.orig Mon May 6 06:17:43 2002
++++ lib/loop_unicode.h Sat Jun 15 14:07:14 2002
@@ -52,8 +52,7 @@
cd->ostate = backup_state;
outptr = backup_outptr;
@@ -16,7 +16,7 @@
outleft = backup_outleft;
- if (sub_outcount < 0)
- return RET_TOOSMALL;
-+ return sub_outcount;
++ return sub_outcount;
}
if (last)
break;
@@ -24,7 +24,7 @@
cd->ostate = backup_state;
outptr = backup_outptr;
outleft = backup_outleft;
-- if (sub_outcount < 0)
+- if (sub_outcount != RET_ILUNI)
- return RET_TOOSMALL;
+ return sub_outcount;
}
diff --git a/converters/libiconv/files/patch-src_Makefile.in b/converters/libiconv/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..105eace66fd2
--- /dev/null
+++ b/converters/libiconv/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat Jun 15 14:25:55 2002
++++ src/Makefile.in Sat Jun 15 14:26:05 2002
+@@ -77,7 +77,7 @@
+ if [ ! -d $(DESTDIR)$(exec_prefix) ] ; then mkdir $(DESTDIR)$(exec_prefix) ; fi
+ if [ ! -d $(DESTDIR)$(bindir) ] ; then mkdir $(DESTDIR)$(bindir) ; fi
+ case "@host_os@" in \
+- hpux*) $(CC) $(LDFLAGS) iconv.@OBJEXT@ -L$(libdir) -liconv @LIBINTL@ -o iconv;; \
++ hpux*|freebsd*) $(CC) $(LDFLAGS) iconv.@OBJEXT@ -L$(libdir) -liconv @LIBINTL@ -o iconv;; \
+ *) $(LIBTOOL_LINK) $(CC) $(LDFLAGS) iconv.@OBJEXT@ $(libdir)/libiconv.la @LTLIBINTL@ -o iconv;; \
+ esac
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) iconv $(DESTDIR)$(bindir)/iconv