aboutsummaryrefslogtreecommitdiffstats
path: root/converters/libiconv
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /converters/libiconv
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'converters/libiconv')
-rw-r--r--converters/libiconv/Makefile6
-rw-r--r--converters/libiconv/files/patch-lib_Makefile.in11
-rw-r--r--converters/libiconv/files/patch-src__Makefile.in8
-rw-r--r--converters/libiconv/pkg-plist3
4 files changed, 6 insertions, 22 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 65c05895a1f1..292acf872c26 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libiconv
PORTVERSION= 1.14
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= converters devel
MASTER_SITES= GNU
@@ -18,7 +18,7 @@ CONFIGURE_ENV= am_cv_func_iconv="yes" \
am_cv_proto_iconv_arg1="const"
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
-USES= libtool:oldver
+USES= libtool
USE_CSTD= gnu89
USE_LDCONFIG= yes
@@ -48,6 +48,6 @@ post-patch:
${WRKSRC}/preload/configure
post-install:
- ${RM} ${STAGEDIR}${PREFIX}/lib/*.la
+ ${LN} -s libiconv.so.2 ${STAGEDIR}${PREFIX}/lib/libiconv.so.3
.include <bsd.port.mk>
diff --git a/converters/libiconv/files/patch-lib_Makefile.in b/converters/libiconv/files/patch-lib_Makefile.in
deleted file mode 100644
index 0b8c2ab636b0..000000000000
--- a/converters/libiconv/files/patch-lib_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig 2011-08-07 19:48:03.000000000 +0200
-+++ lib/Makefile.in 2011-10-23 22:03:44.000000000 +0200
-@@ -50,7 +50,7 @@
-
- # Before making a release, change this according to the libtool documentation,
- # section "Library interface versions".
--LIBICONV_VERSION_INFO = 7:1:5
-+LIBICONV_VERSION_INFO = 3
-
- PACKAGE_VERSION = @VERSION@
-
diff --git a/converters/libiconv/files/patch-src__Makefile.in b/converters/libiconv/files/patch-src__Makefile.in
index fc5bbd58b95d..1cbeaed8769a 100644
--- a/converters/libiconv/files/patch-src__Makefile.in
+++ b/converters/libiconv/files/patch-src__Makefile.in
@@ -8,11 +8,3 @@
# This is the temporary iconv executable, without internationalization.
iconv_no_i18n$(EXEEXT) : iconv_no_i18n.@OBJEXT@ ../lib/libiconv.la $(OBJECTS_RES_@WOE32@)
-@@ -113,6 +112,7 @@
- if [ ! -d $(DESTDIR)$(bindir) ] ; then $(mkinstalldirs) $(DESTDIR)$(bindir) ; fi
- case "@host_os@" in \
- hpux*) $(CC) $(LDFLAGS) $(CFLAGS) $(iconv_LDFLAGS) iconv.@OBJEXT@ ../srclib/libicrt.a -L$(DESTDIR)$(libdir) -liconv @LIBINTL@ $(OBJECTS_RES_@WOE32@) `if test -n '$(DESTDIR)'; then echo " -Wl,+b -Wl,$(libdir)"; fi` -o iconv$(EXEEXT);; \
-+ freebsd*) $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(CFLAGS) $(iconv_LDFLAGS) iconv.@OBJEXT@ ../srclib/libicrt.a ../lib/libiconv.la @LTLIBINTL@ $(OBJECTS_RES_@WOE32@) -o iconv;; \
- *) $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(CFLAGS) $(iconv_LDFLAGS) iconv.@OBJEXT@ ../srclib/libicrt.a $(DESTDIR)$(libdir)/libiconv.la @LTLIBINTL@ $(OBJECTS_RES_@WOE32@) -o iconv$(EXEEXT);; \
- esac
- $(INSTALL_PROGRAM_ENV) $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) iconv$(EXEEXT) $(DESTDIR)$(bindir)/iconv$(EXEEXT)
diff --git a/converters/libiconv/pkg-plist b/converters/libiconv/pkg-plist
index ebed4ef7bb06..0710aabdaac3 100644
--- a/converters/libiconv/pkg-plist
+++ b/converters/libiconv/pkg-plist
@@ -6,8 +6,11 @@ lib/charset.alias
lib/libcharset.a
lib/libcharset.so
lib/libcharset.so.1
+lib/libcharset.so.1.0.0
lib/libiconv.a
lib/libiconv.so
+lib/libiconv.so.2
+lib/libiconv.so.2.5.1
lib/libiconv.so.3
man/man1/iconv.1.gz
man/man3/iconv.3.gz