aboutsummaryrefslogtreecommitdiffstats
path: root/converters/lua-iconv/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2009-12-06 00:33:14 +0800
committervanilla <vanilla@FreeBSD.org>2009-12-06 00:33:14 +0800
commit92420fa42611c0fe56611c30e5f3ad97be3e0652 (patch)
tree52cc663c334a88fcdb9f9b33f78bfddbdd286aca /converters/lua-iconv/Makefile
parent30cb5c20d84996a578a7e2241e06109d18482831 (diff)
downloadfreebsd-ports-gnome-92420fa42611c0fe56611c30e5f3ad97be3e0652.tar.gz
freebsd-ports-gnome-92420fa42611c0fe56611c30e5f3ad97be3e0652.tar.zst
freebsd-ports-gnome-92420fa42611c0fe56611c30e5f3ad97be3e0652.zip
Add lua-iconv, is a lua binding to iconv(3).
Diffstat (limited to 'converters/lua-iconv/Makefile')
-rw-r--r--converters/lua-iconv/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/converters/lua-iconv/Makefile b/converters/lua-iconv/Makefile
new file mode 100644
index 000000000000..c9596f3c0814
--- /dev/null
+++ b/converters/lua-iconv/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: lua-iconv
+# Date created: 04 Dec 2009
+# Whom: vanilla@
+#
+# $FreeBSD$
+#
+
+PORTNAME= iconv
+PORTVERSION= 6
+CATEGORIES= converters
+MASTER_SITES= http://luaforge.net/frs/download.php/4181/
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Iconv binding for Lua 5
+
+WRKSRC= ${WRKDIR}/lua-${PORTNAME}-${PORTVERSION}
+USE_LUA?= 5.1
+USE_GNOME= pkgconfig
+
+PLIST_FILES= %%LUA_MODLIBDIR%%/iconv.so
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%INCDIR%%|-I${PREFIX}/include|;s|%%LIBDIR%%|-L${PREFIX}/lib|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/iconv.so ${LUA_MODLIBDIR}
+
+.include <bsd.port.mk>