aboutsummaryrefslogtreecommitdiffstats
path: root/converters/mmencode
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-12-31 06:51:40 +0800
committerjohans <johans@FreeBSD.org>2012-12-31 06:51:40 +0800
commit50722ad4c465fc3e16ce2d21dc92437638deed7d (patch)
tree457cc45b2f60ba7bb4de5c89aaadcf22517dfb23 /converters/mmencode
parent60ef25267f66eaa83c0d9bad9d7e9a78ec5b8626 (diff)
downloadfreebsd-ports-gnome-50722ad4c465fc3e16ce2d21dc92437638deed7d.tar.gz
freebsd-ports-gnome-50722ad4c465fc3e16ce2d21dc92437638deed7d.tar.zst
freebsd-ports-gnome-50722ad4c465fc3e16ce2d21dc92437638deed7d.zip
- Fix compilation with clang:
Make some implicit function types and references explicit - Adopt port
Diffstat (limited to 'converters/mmencode')
-rw-r--r--converters/mmencode/Makefile8
-rw-r--r--converters/mmencode/files/patch-codes.c85
-rw-r--r--converters/mmencode/files/patch-mmencode.c23
3 files changed, 110 insertions, 6 deletions
diff --git a/converters/mmencode/Makefile b/converters/mmencode/Makefile
index c91c333303f2..a1a1bbe86fb9 100644
--- a/converters/mmencode/Makefile
+++ b/converters/mmencode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mmencode
-# Date created: 30 September 1999
-# Whom: kbyanc
-#
+# Created by: kbyanc
# $FreeBSD$
-#
PORTNAME= mmencode
PORTVERSION= 2.7
@@ -13,7 +9,7 @@ MASTER_SITES= ftp://ftp.delegate.org/pub/mime/mm2.7/ \
DISTNAME= mm${PORTVERSION}
EXTRACT_SUFX= .tar.Z
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= Translate to and from mail-oriented encoding formats
WRKSRC= ${WRKDIR}/${DISTNAME}/src/metamail
diff --git a/converters/mmencode/files/patch-codes.c b/converters/mmencode/files/patch-codes.c
new file mode 100644
index 000000000000..5be683739dc4
--- /dev/null
+++ b/converters/mmencode/files/patch-codes.c
@@ -0,0 +1,85 @@
+--- codes.c.orig 1993-09-20 15:13:22.000000000 +0200
++++ codes.c 2012-12-30 23:36:01.000000000 +0100
+@@ -15,6 +15,7 @@ WITHOUT ANY EXPRESS OR IMPLIED WARRANTIE
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <config.h>
++#include <string.h>
+
+ extern char *index();
+ static char basis_64[] =
+@@ -46,7 +47,9 @@ char c;
+ /* the following gets a character, but fakes it properly into two chars if there's a newline character */
+ static int InNewline=0;
+
+-int nextcharin(infile, PortableNewlines)
++static void output64chunk(int c1, int c2, int c3, int pads, FILE *outfile);
++
++static int nextcharin(infile, PortableNewlines)
+ FILE *infile;
+ int PortableNewlines;
+ {
+@@ -69,6 +72,7 @@ int PortableNewlines;
+ #endif
+ }
+
++void
+ to64(infile, outfile, PortableNewlines)
+ FILE *infile, *outfile;
+ int PortableNewlines;
+@@ -97,6 +101,7 @@ int PortableNewlines;
+ fflush(outfile);
+ }
+
++void
+ output64chunk(c1, c2, c3, pads, outfile)
+ FILE *outfile;
+ {
+@@ -114,6 +119,7 @@ FILE *outfile;
+ }
+ }
+
++static int
+ PendingBoundary(s, Boundaries, BoundaryCt)
+ char *s;
+ char **Boundaries;
+@@ -140,6 +146,7 @@ int *BoundaryCt;
+ static int CRpending = 0;
+
+ #ifdef NEWLINE_CHAR
++static void
+ almostputc(c, outfile, PortableNewlines)
+ int c;
+ FILE *outfile;
+@@ -165,6 +172,7 @@ int PortableNewlines;
+ }
+ }
+ #else
++static void
+ almostputc(c, outfile, PortableNewlines)
+ int c;
+ FILE *outfile;
+@@ -174,6 +182,7 @@ int PortableNewlines;
+ }
+ #endif
+
++void
+ from64(infile, outfile, boundaries, boundaryct, PortableNewlines)
+ FILE *infile, *outfile;
+ char **boundaries;
+@@ -275,6 +284,7 @@ char c;
+ }
+ */
+
++void
+ toqp(infile, outfile)
+ FILE *infile, *outfile;
+ {
+@@ -350,6 +360,7 @@ FILE *infile, *outfile;
+ }
+ }
+
++void
+ fromqp(infile, outfile, boundaries, boundaryct)
+ FILE *infile, *outfile;
+ char **boundaries;
diff --git a/converters/mmencode/files/patch-mmencode.c b/converters/mmencode/files/patch-mmencode.c
new file mode 100644
index 000000000000..f24e31a0b5cf
--- /dev/null
+++ b/converters/mmencode/files/patch-mmencode.c
@@ -0,0 +1,23 @@
+--- mmencode.c.orig 2012-12-30 23:29:36.000000000 +0100
++++ mmencode.c 2012-12-30 23:30:33.000000000 +0100
+@@ -14,6 +14,7 @@ WITHOUT ANY EXPRESS OR IMPLIED WARRANTIE
+ */
+ #include <stdio.h>
+ #include <config.h>
++#include <stdlib.h>
+ #ifdef MSDOS
+ #include <fcntl.h>
+ #endif
+@@ -21,6 +22,12 @@ WITHOUT ANY EXPRESS OR IMPLIED WARRANTIE
+ #define BASE64 1
+ #define QP 2 /* quoted-printable */
+
++extern void to64(FILE *infile, FILE *outfile, int PortableNewlines);
++extern void from64(FILE *infile, FILE *outfile, char **boundaries, int *boundaryct, int PortableNewlines);
++extern void toqp(FILE *infile, FILE *outfile);
++extern void fromqp(FILE *infile, FILE *outfile, char **boundaries, int *boundaryct);
++
++int
+ main(argc, argv)
+ int argc;
+ char **argv;