aboutsummaryrefslogtreecommitdiffstats
path: root/converters/osm2mp
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-06-22 21:43:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-06-22 21:43:45 +0800
commitde877cb7673a36f4c49d23150d0ca5360a5b9a65 (patch)
tree678b707ee62e62e98a7176bfc440eeffa14a6618 /converters/osm2mp
parent7f36b2d1d8e34f3a8b3cd364fada4253f7e89095 (diff)
downloadfreebsd-ports-gnome-de877cb7673a36f4c49d23150d0ca5360a5b9a65.tar.gz
freebsd-ports-gnome-de877cb7673a36f4c49d23150d0ca5360a5b9a65.tar.zst
freebsd-ports-gnome-de877cb7673a36f4c49d23150d0ca5360a5b9a65.zip
OpenStreetMap data into Polish map format (MP) convertor
WWW: http://code.google.com/p/osm2mp/
Diffstat (limited to 'converters/osm2mp')
-rw-r--r--converters/osm2mp/Makefile42
-rw-r--r--converters/osm2mp/distinfo2
-rw-r--r--converters/osm2mp/files/pkg-message.in3
-rw-r--r--converters/osm2mp/pkg-descr3
-rw-r--r--converters/osm2mp/pkg-plist35
5 files changed, 85 insertions, 0 deletions
diff --git a/converters/osm2mp/Makefile b/converters/osm2mp/Makefile
new file mode 100644
index 000000000000..3a403f87cea8
--- /dev/null
+++ b/converters/osm2mp/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: osm2mp
+# Date created: 21 Jun 2011
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osm2mp
+PORTVERSION= r475
+CATEGORIES= converters geography
+MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= OpenStreetMap data into Polish map format (MP) convertor
+
+RUN_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/Encode/Locale.pm:${PORTSDIR}/converters/p5-Encode-Locale \
+ ${SITE_PERL}/Math/Polygon.pm:${PORTSDIR}/math/p5-Math-Polygon \
+ ${SITE_PERL}/Math/Polygon/Tree.pm:${PORTSDIR}/math/p5-Math-Polygon-Tree \
+ ${SITE_PERL}/Tree/R.pm:${PORTSDIR}/devel/p5-Tree-R \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC/Polygon.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC-Polygon \
+ ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils
+
+LICENSE= GPLv2
+
+USE_BZIP2= yes
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+SUB_FILES= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|garmin.yml|${DATADIR}/&|' ${WRKSRC}/osm2mp.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/osm2mp.pl ${PREFIX}/bin/osm2mp
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} '*.cmap *.yml *.txt *.typ polish-mp' ${DATADIR}/
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/converters/osm2mp/distinfo b/converters/osm2mp/distinfo
new file mode 100644
index 000000000000..dc08279a09aa
--- /dev/null
+++ b/converters/osm2mp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (osm2mp-r475.tar.bz2) = 9ca7083594a6b433d7bf515587cc7d55650a9f7041fafc442c7dd838d1d4d65c
+SIZE (osm2mp-r475.tar.bz2) = 47053
diff --git a/converters/osm2mp/files/pkg-message.in b/converters/osm2mp/files/pkg-message.in
new file mode 100644
index 000000000000..7855063b879d
--- /dev/null
+++ b/converters/osm2mp/files/pkg-message.in
@@ -0,0 +1,3 @@
+If you need to tune osm2mp configuration files, you may copy
+%%DATADIR%% to some directory you own and use
+osm2mp's --config option to point it to modified files.
diff --git a/converters/osm2mp/pkg-descr b/converters/osm2mp/pkg-descr
new file mode 100644
index 000000000000..3a7c72f8bd4f
--- /dev/null
+++ b/converters/osm2mp/pkg-descr
@@ -0,0 +1,3 @@
+OpenStreetMap data into Polish map format (MP) convertor
+
+WWW: http://code.google.com/p/osm2mp/
diff --git a/converters/osm2mp/pkg-plist b/converters/osm2mp/pkg-plist
new file mode 100644
index 000000000000..d89902306626
--- /dev/null
+++ b/converters/osm2mp/pkg-plist
@@ -0,0 +1,35 @@
+bin/osm2mp
+%%DATADIR%%/cp1250.cmap
+%%DATADIR%%/cp1251.cmap
+%%DATADIR%%/garmin-auto-ru.yml
+%%DATADIR%%/garmin-auto.yml
+%%DATADIR%%/garmin-ru.yml
+%%DATADIR%%/garmin-water.yml
+%%DATADIR%%/garmin.yml
+%%DATADIR%%/iso-3166-1-a2-en.txt
+%%DATADIR%%/iso-3166-1-a2-ru.txt
+%%DATADIR%%/osm.typ
+%%DATADIR%%/osm_pv.txt
+%%DATADIR%%/polish-mp/nodes-common-en.yml
+%%DATADIR%%/polish-mp/nodes-common-ru.yml
+%%DATADIR%%/polish-mp/nodes-common-univ.yml
+%%DATADIR%%/polish-mp/nodes-common.yml
+%%DATADIR%%/polish-mp/nodes-garmin-custom-univ.yml
+%%DATADIR%%/polish-mp/nodes-garmin-custom.yml
+%%DATADIR%%/polish-mp/nodes-garmin-marine.yml
+%%DATADIR%%/polish-mp/output-polish.yml
+%%DATADIR%%/polish-mp/ways-areas-common-univ.yml
+%%DATADIR%%/polish-mp/ways-areas-common.yml
+%%DATADIR%%/polish-mp/ways-areas-garmin-custom-univ.yml
+%%DATADIR%%/polish-mp/ways-areas-garmin-custom.yml
+%%DATADIR%%/polish-mp/ways-lines-common-univ.yml
+%%DATADIR%%/polish-mp/ways-lines-common.yml
+%%DATADIR%%/polish-mp/ways-lines-garmin-custom-univ.yml
+%%DATADIR%%/polish-mp/ways-lines-garmin-custom.yml
+%%DATADIR%%/polish-mp/ways-roads-common-univ.yml
+%%DATADIR%%/polish-mp/ways-roads-common.yml
+%%DATADIR%%/polish-mp/ways-roads-garmin-univ.yml
+%%DATADIR%%/polish-mp/ways-roads-garmin.yml
+%%DATADIR%%/polish-mp/ways-roads-waterway.yml
+@dirrm %%DATADIR%%/polish-mp
+@dirrm %%DATADIR%%