aboutsummaryrefslogtreecommitdiffstats
path: root/converters/p5-Convert-PEM
diff options
context:
space:
-rw-r--r--converters/p5-Convert-PEM/Makefile3
-rw-r--r--converters/p5-Convert-PEM/pkg-plist6
2 files changed, 5 insertions, 4 deletions
diff --git a/converters/p5-Convert-PEM/Makefile b/converters/p5-Convert-PEM/Makefile
index cd2071271415..bba18b2607ea 100644
--- a/converters/p5-Convert-PEM/Makefile
+++ b/converters/p5-Convert-PEM/Makefile
@@ -18,7 +18,4 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Convert::PEM.3 Convert::PEM::CBC.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/converters/p5-Convert-PEM/pkg-plist b/converters/p5-Convert-PEM/pkg-plist
index 7fb99b11fda9..e0a5b8394308 100644
--- a/converters/p5-Convert-PEM/pkg-plist
+++ b/converters/p5-Convert-PEM/pkg-plist
@@ -1,5 +1,9 @@
+%%PERL5_MAN3%%/Convert::PEM.3.gz
+%%PERL5_MAN3%%/Convert::PEM::CBC.3.gz
%%SITE_PERL%%/Convert/PEM.pm
%%SITE_PERL%%/Convert/PEM/CBC.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Convert/PEM/.packlist
-@dirrm %%SITE_PERL%%/Convert/PEM
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Convert/PEM
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Convert
+@dirrm %%SITE_PERL%%/Convert/PEM
+@dirrmtry %%SITE_PERL%%/Convert
span> /* query_auth_types returns a GList of these */ typedef struct { char *name, *description, *authproto; gboolean need_password; } CamelServiceAuthType; /* public methods */ void camel_service_construct (CamelService *service, CamelSession *session, CamelProvider *provider, CamelURL *url, CamelException *ex); gboolean camel_service_connect (CamelService *service, CamelException *ex); gboolean camel_service_disconnect (CamelService *service, gboolean clean, CamelException *ex); char * camel_service_get_url (CamelService *service); char * camel_service_get_name (CamelService *service, gboolean brief); char * camel_service_get_path (CamelService *service); CamelSession * camel_service_get_session (CamelService *service); CamelProvider * camel_service_get_provider (CamelService *service); GList * camel_service_query_auth_types (CamelService *service, CamelException *ex); /* convenience functions */ struct hostent * camel_service_gethost (CamelService *service, CamelException *ex); /* cancellable dns lookup */ struct hostent * camel_get_host_byname (const char *name, CamelException *ex); void camel_free_host (struct hostent *h); /* Standard Camel function */ CamelType camel_service_get_type (void); #ifdef __cplusplus } #endif /* __cplusplus */ #endif /* CAMEL_SERVICE_H */