aboutsummaryrefslogtreecommitdiffstats
path: root/converters/p5-Cpanel-JSON-XS/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-07 02:56:00 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-07 02:56:00 +0800
commit586de24eaf85782255843c913eaebcf02b735775 (patch)
tree18fd3f05f42d716a6ee7892b2e67c6311747294c /converters/p5-Cpanel-JSON-XS/Makefile
parent0ceb4cb149263c524994eb37ac99a617a0476ce8 (diff)
downloadfreebsd-ports-gnome-586de24eaf85782255843c913eaebcf02b735775.tar.gz
freebsd-ports-gnome-586de24eaf85782255843c913eaebcf02b735775.tar.zst
freebsd-ports-gnome-586de24eaf85782255843c913eaebcf02b735775.zip
- Add p5-Cpanel-JSON-XS 2.3403
Cpanel::JSON::XS converts Perl data structures to JSON and vice versa. Its primary goal is to be correct and its secondary goal is to be fast. To reach the latter goal it was written in C. As this is the n-th-something JSON module on CPAN, what was the reason to write yet another JSON module? While it seems there are many JSON modules, none of them correctly handle all corner cases, and in most cases their maintainers are unresponsive, gone missing, or not listening to bug reports for other reasons. WWW: http://search.cpan.org/dist/Cpanel-JSON-XS/
Diffstat (limited to 'converters/p5-Cpanel-JSON-XS/Makefile')
-rw-r--r--converters/p5-Cpanel-JSON-XS/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/converters/p5-Cpanel-JSON-XS/Makefile b/converters/p5-Cpanel-JSON-XS/Makefile
new file mode 100644
index 000000000000..25afc6d26e72
--- /dev/null
+++ b/converters/p5-Cpanel-JSON-XS/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Cpanel-JSON-XS
+PORTVERSION= 2.34.03
+CATEGORIES= converters perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RURBAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= JSON::XS for Cpanel, fast and correct serialising
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>