aboutsummaryrefslogtreecommitdiffstats
path: root/converters/p5-Unicode-Lite
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2003-07-03 22:47:16 +0800
committerkuriyama <kuriyama@FreeBSD.org>2003-07-03 22:47:16 +0800
commit4fa751b453cd08c6800ae3d0b46914981a2880b0 (patch)
tree58a15b20dd29c432ba79d876163ef1620bc68b16 /converters/p5-Unicode-Lite
parentebbea2c6e78f4080e6b7c3c02db4380473b4965f (diff)
downloadfreebsd-ports-gnome-4fa751b453cd08c6800ae3d0b46914981a2880b0.tar.gz
freebsd-ports-gnome-4fa751b453cd08c6800ae3d0b46914981a2880b0.tar.zst
freebsd-ports-gnome-4fa751b453cd08c6800ae3d0b46914981a2880b0.zip
Add p5-Unicode-Lite 0.12,
perl module for easy conversion between encodings. PR: ports/50207 Submitted by: Maxim Maximov (mcsi@agava.com)
Diffstat (limited to 'converters/p5-Unicode-Lite')
-rw-r--r--converters/p5-Unicode-Lite/Makefile28
-rw-r--r--converters/p5-Unicode-Lite/distinfo1
-rw-r--r--converters/p5-Unicode-Lite/pkg-descr10
-rw-r--r--converters/p5-Unicode-Lite/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/converters/p5-Unicode-Lite/Makefile b/converters/p5-Unicode-Lite/Makefile
new file mode 100644
index 000000000000..2a99e6bb30a9
--- /dev/null
+++ b/converters/p5-Unicode-Lite/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Unicode-Lite
+# Date created: 23th March 2003
+# Whom: Maxim Maximov (mcsi@agava.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Unicode-Lite
+PORTVERSION= 0.12
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Unicode
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mcsi@agava.com
+COMMENT= Perl module for easy conversion between encodings
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
+ ${SITE_PERL}/${PERL_ARCH}/Unicode/Map.pm:${PORTSDIR}/converters/p5-Unicode-Map \
+ ${SITE_PERL}/enum.pm:${PORTSDIR}/devel/p5-enum
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Unicode::Lite.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/converters/p5-Unicode-Lite/distinfo b/converters/p5-Unicode-Lite/distinfo
new file mode 100644
index 000000000000..59b6c0deeabf
--- /dev/null
+++ b/converters/p5-Unicode-Lite/distinfo
@@ -0,0 +1 @@
+MD5 (Unicode-Lite-0.12.tar.gz) = f8fa78a8c113bf8b42cba6e3cb9b8797
diff --git a/converters/p5-Unicode-Lite/pkg-descr b/converters/p5-Unicode-Lite/pkg-descr
new file mode 100644
index 000000000000..5fa87cc35189
--- /dev/null
+++ b/converters/p5-Unicode-Lite/pkg-descr
@@ -0,0 +1,10 @@
+This module includes string converting function from one and to another
+charset. Requires installed Unicode::String and Unicode::Map packages.
+
+Supported unicode charsets: unicode, utf16, ucs2, utf8, utf7, ucs4,
+uchr, uhex.
+
+Supported Single-Byte Charsets (SBCS): latin1 and all installed maps in
+Unicode::Map package.
+
+WWW: http://search.cpan.org/dist/Unicode-Lite/
diff --git a/converters/p5-Unicode-Lite/pkg-plist b/converters/p5-Unicode-Lite/pkg-plist
new file mode 100644
index 000000000000..43d27499d948
--- /dev/null
+++ b/converters/p5-Unicode-Lite/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Unicode/Lite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unicode/Lite/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Unicode/Lite
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unicode 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Unicode 2>/dev/null || true