aboutsummaryrefslogtreecommitdiffstats
path: root/converters/p5-Unicode-MapUTF8/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-25 22:09:00 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-25 22:09:00 +0800
commit98d207a4906ce7a49b929135dbceee82bdff0f21 (patch)
treec52a6d0974791f8a94136a6e6f15ff328e061e75 /converters/p5-Unicode-MapUTF8/Makefile
parent78ec03a3238983555184d0249b2d6d81d17bc976 (diff)
downloadfreebsd-ports-gnome-98d207a4906ce7a49b929135dbceee82bdff0f21.tar.gz
freebsd-ports-gnome-98d207a4906ce7a49b929135dbceee82bdff0f21.tar.zst
freebsd-ports-gnome-98d207a4906ce7a49b929135dbceee82bdff0f21.zip
add p5-Unicode-MapUTF8 1.09
Perl class that implements conversion between arbitrary charsets PR: 35406 Submitted by: Ryan T. Dean <rtdean@cytherianage.net>
Diffstat (limited to 'converters/p5-Unicode-MapUTF8/Makefile')
-rw-r--r--converters/p5-Unicode-MapUTF8/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/converters/p5-Unicode-MapUTF8/Makefile b/converters/p5-Unicode-MapUTF8/Makefile
new file mode 100644
index 000000000000..b413e5f345ff
--- /dev/null
+++ b/converters/p5-Unicode-MapUTF8/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Unicode-MapUTF8
+# Date created: 28 February 2002
+# Whom: Ryan T. Dean <rtdean@cytherianage.net>
+#
+# $FreeBSD$
+
+PORTNAME= Unicode-MapUTF8
+PORTVERSION= 1.09
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Unicode
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rtdean@cytherianage.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unicode/Map.pm:${PORTSDIR}/converters/p5-Unicode-Map \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-Map8 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Unicode::MapUTF8.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>