aboutsummaryrefslogtreecommitdiffstats
path: root/converters/p5-Unicode-String/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-09-20 00:56:32 +0800
committerade <ade@FreeBSD.org>2000-09-20 00:56:32 +0800
commit905faef160c258a799cf4abd3c32c7c63a84a0f1 (patch)
treef8d052413116faf71873ac92f87dce61678e829d /converters/p5-Unicode-String/Makefile
parent483b40e7eebc07d20e70c7a17bb5b50f2e736797 (diff)
downloadfreebsd-ports-gnome-905faef160c258a799cf4abd3c32c7c63a84a0f1.tar.gz
freebsd-ports-gnome-905faef160c258a799cf4abd3c32c7c63a84a0f1.tar.zst
freebsd-ports-gnome-905faef160c258a799cf4abd3c32c7c63a84a0f1.zip
Add p5-Unicode-String, a perl5 module needed for writing CGI programs
with different national languages PR: 21164 Submitted by: Ilia Chipitsine <ilia@jane.cgu.chel.su>
Diffstat (limited to 'converters/p5-Unicode-String/Makefile')
-rw-r--r--converters/p5-Unicode-String/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/converters/p5-Unicode-String/Makefile b/converters/p5-Unicode-String/Makefile
new file mode 100644
index 000000000000..54ee6c510695
--- /dev/null
+++ b/converters/p5-Unicode-String/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Unicode-String
+# Date created: 10th September 2000
+# Whom: Ilia Chipitsine <ilia@jane.cgu.chel.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Unicode-String
+PORTVERSION= 2.06
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Unicode
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ilia@cgu.chel.su
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+USE_PERL5= yes
+
+MAN3= Unicode::CharName.3 Unicode::String.3
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>