aboutsummaryrefslogtreecommitdiffstats
path: root/converters/p5-XML-WBXML
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-26 05:51:54 +0800
committeraaron <aaron@FreeBSD.org>2006-05-26 05:51:54 +0800
commit54a95807827bd3ce6d9760147447f6399aeb4efe (patch)
tree270a39917afd3d1ef7a7e7fc9cf40dfeec450c04 /converters/p5-XML-WBXML
parenta27dd2b191df20a57ec9622d35df392f7c90f5ea (diff)
downloadfreebsd-ports-gnome-54a95807827bd3ce6d9760147447f6399aeb4efe.tar.gz
freebsd-ports-gnome-54a95807827bd3ce6d9760147447f6399aeb4efe.tar.zst
freebsd-ports-gnome-54a95807827bd3ce6d9760147447f6399aeb4efe.zip
- Tweaked source to allow use under Perl 5.6
Approved by: tobez (implicit)
Diffstat (limited to 'converters/p5-XML-WBXML')
-rw-r--r--converters/p5-XML-WBXML/Makefile4
-rw-r--r--converters/p5-XML-WBXML/files/patch-Makefile.PL8
-rw-r--r--converters/p5-XML-WBXML/files/patch-WBXML.pm10
3 files changed, 19 insertions, 3 deletions
diff --git a/converters/p5-XML-WBXML/Makefile b/converters/p5-XML-WBXML/Makefile
index 835e53ba9b4a..ab04556a4075 100644
--- a/converters/p5-XML-WBXML/Makefile
+++ b/converters/p5-XML-WBXML/Makefile
@@ -23,8 +23,8 @@ PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500800
-IGNORE= currently requires Perl 5.8. Please install lang/perl5.8 and try again
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>
diff --git a/converters/p5-XML-WBXML/files/patch-Makefile.PL b/converters/p5-XML-WBXML/files/patch-Makefile.PL
index cb94e745e055..f9958740ffaf 100644
--- a/converters/p5-XML-WBXML/files/patch-Makefile.PL
+++ b/converters/p5-XML-WBXML/files/patch-Makefile.PL
@@ -1,5 +1,11 @@
--- Makefile.PL Thu Aug 11 19:31:58 2005
-+++ Makefile.PL Thu May 25 15:13:58 2006
++++ Makefile.PL Thu May 25 15:42:44 2006
+@@ -1,4 +1,4 @@
+-use 5.008003;
++use 5.00600;
+ use ExtUtils::MakeMaker;
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
@@ -8,9 +8,9 @@
PREREQ_PM => {}, # e.g., Module::Name => 1.1
ABSTRACT_FROM => 'lib/XML/WBXML.pm', # retrieve abstract from module
diff --git a/converters/p5-XML-WBXML/files/patch-WBXML.pm b/converters/p5-XML-WBXML/files/patch-WBXML.pm
new file mode 100644
index 000000000000..5bd78fc3fda4
--- /dev/null
+++ b/converters/p5-XML-WBXML/files/patch-WBXML.pm
@@ -0,0 +1,10 @@
+--- lib/XML/WBXML.pm Thu Aug 11 20:55:31 2005
++++ lib/XML/WBXML.pm Thu May 25 15:47:21 2006
+@@ -1,6 +1,6 @@
+ package XML::WBXML;
+
+-use 5.008003;
++use 5.00600;
+ use strict;
+ use warnings;
+