aboutsummaryrefslogtreecommitdiffstats
path: root/converters/trans
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>1996-11-27 18:59:59 +0800
committerache <ache@FreeBSD.org>1996-11-27 18:59:59 +0800
commitfc22970c41af06293d1af13ae96d5791263296e0 (patch)
tree0980fa573568ce53f2e5b0808e8da5cf0c0b5344 /converters/trans
parent6c1870fa41d985bc4f9df4dcf03a5c404408d702 (diff)
downloadfreebsd-ports-gnome-fc22970c41af06293d1af13ae96d5791263296e0.tar.gz
freebsd-ports-gnome-fc22970c41af06293d1af13ae96d5791263296e0.tar.zst
freebsd-ports-gnome-fc22970c41af06293d1af13ae96d5791263296e0.zip
Add missing files
More freebsd tunings
Diffstat (limited to 'converters/trans')
-rw-r--r--converters/trans/Makefile26
-rw-r--r--converters/trans/files/patch-aa48
-rw-r--r--converters/trans/pkg-plist3
3 files changed, 29 insertions, 48 deletions
diff --git a/converters/trans/Makefile b/converters/trans/Makefile
index b1b47ace73bc..aff136df7715 100644
--- a/converters/trans/Makefile
+++ b/converters/trans/Makefile
@@ -1,9 +1,9 @@
# New ports collection makefile for: trans
# Version required: 1.11
# Date created: 6 May 1996
-# Whom: ache@astral.msk.su
+# Whom: ache
#
-# $Id: Makefile,v 1.1.1.1 1996/05/06 13:33:38 ache Exp $
+# $Id: Makefile,v 1.2 1996/07/13 22:41:46 ache Exp $
#
DISTNAME= trans111
@@ -11,6 +11,26 @@ PKGNAME= trans-1.11
CATEGORIES= misc russian
MASTER_SITES= ftp://ftp.informatik.uni-erlangen.de/pub/doc/ISO/charsets/
-MAINTAINER= ache@astral.msk.su
+MAINTAINER= ache@FreeBSD.org
+
+LIBDIR= ${PREFIX}/lib/trans
+ALL= transtab transiso checkiso transce8
+
+do-install:
+ cd ${WRKSRC} && $(INSTALL_PROGRAM) $(ALL) ${PREFIX}/bin
+ cd ${WRKSRC} && \
+ for i in $(ALL); do \
+ $(INSTALL_MAN) $$i.man ${PREFIX}/man/cat1/$$i.1; \
+ done
+ -mkdir -p ${LIBDIR}/tables ${LIBDIR}/xlt ${LIBDIR}/doc
+ cd ${WRKSRC} && \
+ $(INSTALL_SCRIPT) checkall mkbintab mklist one iso ${LIBDIR}
+ cd ${WRKSRC} && \
+ $(INSTALL_DATA) iso10646 encoding.lis bin/trans.[ch] bin/trans.man \
+ bin/utimbuf.h bin/utf.[ch] ${LIBDIR}
+ cd ${WRKSRC}/tables && $(INSTALL_DATA) * ${LIBDIR}/tables
+ cd ${WRKSRC}/xlt && $(INSTALL_DATA) * ${LIBDIR}/xlt
+ cd ${WRKSRC}/doc && $(INSTALL_DATA) * ${LIBDIR}/doc
+
.include <bsd.port.mk>
diff --git a/converters/trans/files/patch-aa b/converters/trans/files/patch-aa
index 2d89bec82c81..9b29b1d85561 100644
--- a/converters/trans/files/patch-aa
+++ b/converters/trans/files/patch-aa
@@ -1,7 +1,7 @@
*** Makefile.orig Sat Jun 1 04:11:00 1996
---- Makefile Sun Jul 14 02:24:09 1996
+--- Makefile Wed Nov 27 13:01:22 1996
***************
-*** 30,49 ****
+*** 30,43 ****
#
# CC = bcc
# CC = cl
@@ -16,13 +16,7 @@
#
# LOPTS are linker options (if any)
#
- # LOPTS =
- # LOPTS = /F 4000
- LOPTS = -o
- #
- # OBJLIB is the collection of independend object files
- #
---- 30,54 ----
+--- 30,44 ----
#
# CC = bcc
# CC = cl
@@ -38,39 +32,3 @@
#
# LOPTS are linker options (if any)
#
- # LOPTS =
- # LOPTS = /F 4000
- LOPTS = -o
-+
-+ PREFIX = /usr/local
-+ LIBDIR = ${PREFIX}/lib/trans
-+
- #
- # OBJLIB is the collection of independend object files
- #
-***************
-*** 62,68 ****
- #
-
- install:
-! cp $(ALL) /usr/local/bin
-
- #
- ###############################################################################
---- 67,82 ----
- #
-
- install:
-! $(INSTALL) -s -c -m $(BINMODE) -o $(BINOWN) -g $(BINGRP) $(ALL) ${PREFIX}/bin
-! for i in $(ALL); do \
-! $(INSTALL) -c -m $(MANMODE) -o $(MANOWN) -g $(MANGRP) $$i.man ${PREFIX}/man/cat1/$$i.1; \
-! done
-! -mkdir -p ${LIBDIR}/tables ${LIBDIR}/xlt ${LIBDIR}/doc
-! $(INSTALL) -c -m $(BINMODE) -o $(BINOWN) -g $(BINGRP) checkall mkbintab mklist one iso ${LIBDIR}
-! $(INSTALL) -c -m $(SHAREMODE) -o $(SHAREOWN) -g $(SHAREGRP) iso10646 encoding.lis bin/trans.[ch] bin/trans.man ${LIBDIR}
-! cd tables; $(INSTALL) -c -m $(SHAREMODE) -o $(SHAREOWN) -g $(SHAREGRP) * ${LIBDIR}/tables
-! cd xlt; $(INSTALL) -c -m $(SHAREMODE) -o $(SHAREOWN) -g $(SHAREGRP) * ${LIBDIR}/xlt
-! cd doc; $(INSTALL) -c -m $(SHAREMODE) -o $(SHAREOWN) -g $(SHAREGRP) * ${LIBDIR}/doc
-
- #
- ###############################################################################
diff --git a/converters/trans/pkg-plist b/converters/trans/pkg-plist
index 9a2140b7e71b..f04e6bdd9e61 100644
--- a/converters/trans/pkg-plist
+++ b/converters/trans/pkg-plist
@@ -208,3 +208,6 @@ lib/trans/iso10646
lib/trans/trans.c
lib/trans/trans.h
lib/trans/trans.man
+lib/trans/utimbuf.h
+lib/trans/utf.c
+lib/trans/utf.h