aboutsummaryrefslogtreecommitdiffstats
path: root/converters/utf8conv
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-31 01:37:26 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-31 01:37:26 +0800
commit4317a8024a1113afac390b052f38f4101ccc1229 (patch)
tree75ccf0f0b1e44f5b4247565efdf6d6db798938dc /converters/utf8conv
parent24adce702a003726cb5d13b853db73d970ed16f5 (diff)
downloadfreebsd-ports-gnome-4317a8024a1113afac390b052f38f4101ccc1229.tar.gz
freebsd-ports-gnome-4317a8024a1113afac390b052f38f4101ccc1229.tar.zst
freebsd-ports-gnome-4317a8024a1113afac390b052f38f4101ccc1229.zip
add utf8conv
Convert hexadecimal Unicode character values to UTF-8
Diffstat (limited to 'converters/utf8conv')
-rw-r--r--converters/utf8conv/Makefile26
-rw-r--r--converters/utf8conv/distinfo1
-rw-r--r--converters/utf8conv/pkg-comment1
-rw-r--r--converters/utf8conv/pkg-descr1
-rw-r--r--converters/utf8conv/pkg-plist1
5 files changed, 30 insertions, 0 deletions
diff --git a/converters/utf8conv/Makefile b/converters/utf8conv/Makefile
new file mode 100644
index 000000000000..2ba322dc17bb
--- /dev/null
+++ b/converters/utf8conv/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: utf8conv
+# Date created: Jul 30, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= utf8conv
+PORTVERSION= 1.0.1
+CATEGORIES= converters
+MASTER_SITES= http://www.fibrespeed.net/~mbabcock/code/
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.0
+ALL_TARGET= ${PORTNAME}
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; \
+ s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/utf8conv ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/converters/utf8conv/distinfo b/converters/utf8conv/distinfo
new file mode 100644
index 000000000000..83e048826643
--- /dev/null
+++ b/converters/utf8conv/distinfo
@@ -0,0 +1 @@
+MD5 (utf8conv-1.0.1.tar.gz) = 1687031b756ab14d00c722dffac15abd
diff --git a/converters/utf8conv/pkg-comment b/converters/utf8conv/pkg-comment
new file mode 100644
index 000000000000..9d7230382852
--- /dev/null
+++ b/converters/utf8conv/pkg-comment
@@ -0,0 +1 @@
+Convert hexadecimal Unicode character values to UTF-8
diff --git a/converters/utf8conv/pkg-descr b/converters/utf8conv/pkg-descr
new file mode 100644
index 000000000000..9d7230382852
--- /dev/null
+++ b/converters/utf8conv/pkg-descr
@@ -0,0 +1 @@
+Convert hexadecimal Unicode character values to UTF-8
diff --git a/converters/utf8conv/pkg-plist b/converters/utf8conv/pkg-plist
new file mode 100644
index 000000000000..c2773029fad0
--- /dev/null
+++ b/converters/utf8conv/pkg-plist
@@ -0,0 +1 @@
+bin/utf8conv